Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Installing The RadeonHD Driver On Ubuntu

  1. #1
    Join Date
    Jan 2007
    Posts
    13,456

    Default Installing The RadeonHD Driver On Ubuntu

    Phoronix: Installing The RadeonHD Driver On Ubuntu

    While today's unveiling of the RadeonHD driver for the ATI R500 and R600 series is great news, this driver right now is targeted solely for developers as it's still experimental and doesn't yet support 3D acceleration and other key functionality generally needed in production environments. However, if you are looking to try out this new RadeonHD driver on Ubuntu because you're running into problems with the proprietary fglrx driver or just wishing to report your results, we've documented the installation procedures for Ubuntu.

    http://www.phoronix.com/vr.php?view=11067

  2. #2
    Join Date
    Sep 2007
    Posts
    6

    Default checkinstall

    In Debian or Ubuntu, it's better to use "checkinstall make install" than just "make install"... the former builds a .deb package, which can easily be uninstalled if desired.

    Just install the checkinstall package when you install build-essential, git-core, etc. I've installed the RadeonHD this way on my laptop (you just need to tinker with the version number when you build the package... call it git20070917 or something).

  3. #3
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,092

    Default

    "checkinstall make install"

    I think you're talking about "checkinstall" as a command.

    And checkinstall really isn't necesssary.

  4. #4
    Join Date
    Jun 2006
    Location
    Gdansk, Polska
    Posts
    30

    Default

    Thanks for the guide! I've followed the steps and have restarted.

    How can I check that I'm using the RadeonHD driver?

  5. #5
    Join Date
    Sep 2007
    Posts
    26

    Default

    Quote Originally Posted by Radon View Post
    Thanks for the guide! I've followed the steps and have restarted.

    How can I check that I'm using the RadeonHD driver?
    Check /var/log/Xorg.0.log

    Check for something like this:

    Code:
    (II) RADEONHD: version 0.0.4, built from non-git sources

  6. #6
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,092

    Default

    Somebody using Ubuntu could try if the Debian package works:

    http://packages.debian.org/sid/x11/x...video-radeonhd

    It is RadeonHD v1.0.0 at the moment.

  7. #7
    Join Date
    Sep 2007
    Posts
    26

    Default

    Quote Originally Posted by d2kx View Post
    Somebody using Ubuntu could try if the Debian package works:

    http://packages.debian.org/sid/x11/x...video-radeonhd

    It is RadeonHD v1.0.0 at the moment.

    It does...

  8. #8
    Join Date
    Oct 2007
    Posts
    1,187

    Unhappy

    Gave it a shot. Tried both the git method and the official 1.0 tarball. It doesn't seem to like my integrated X1250 on my MSI K9AG Neo2-Digital.
    Code:
    (II) RADEONHD(0): Unknown card detected: 0x791E:0x1462:0x7327.
    	If your card does not work or does not work optimally
    	please contact radeonhd@opensuse.org to help rectify this.
    	Use the subject: 0x791E:0x1462:0x7327: <name of board>.
    (--) RADEONHD(0): Detected an RS690 on an unidentified card
    (II) RADEONHD(0): Mapped IO at 0x2b1f243d9000 (size 0x00010000)
    (II) RADEONHD(0): Getting BIOS copy from legacy VBIOS location
    (II) RADEONHD(0): ATOM BIOS Rom: 
    	SubsystemVendorID: 0x1002 SubsystemID: 0x791e
    	IOBaseAddress: 0xc000
    	Filename: MS7368_2.bin
    	BIOS Bootup Message: 
    
    ATI Radeon Xpress for MS7368

  9. #9
    Join Date
    Dec 2007
    Posts
    12

    Default

    Hi all, i'm queuing up for assistance
    My rig has got a hd2600Pro AGP.
    On Gutsy i've been able to compile the radeonhd 1.0 driver as explained in the guide here at phoronix.

    Here's what xorg tells me after rebooting

    Code:
    [cut]
    (EE) RADEONHD(0): RandR: No valid modes. Disabled.
    (==) RADEONHD(0): RGB weight 888
    (==) RADEONHD(0): Default visual is TrueColor
    (==) RADEONHD(0): Using gamma correction (1.0, 1.0, 1.0)
    (II) RADEONHD(0): Using 0x0 Framebuffer with 0 pitch
    (==) RADEONHD(0): DPI set to (100, 100)
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib/xorg/modules//libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	ABI class: X.Org ANSI C Emulation, version 0.3
    (II) Loading sub module "xaa"
    (II) LoadModule: "xaa"
    (II) Loading /usr/lib/xorg/modules//libxaa.so
    (II) Module xaa: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.2.0
    	ABI class: X.Org Video Driver, version 1.2
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"(II) Module already built-in
    (II) Loading sub module "shadow"
    (II) LoadModule: "shadow"
    (II) Loading /usr/lib/xorg/modules//libshadow.so
    (II) Module shadow: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.1.0
    	ABI class: X.Org ANSI C Emulation, version 0.3
    (II) RADEONHD(0): Using ShadowFB
    
    Backtrace:
    0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
    1: [0xffffe420]
    2: /usr/bin/X(InitOutput+0xb46) [0x80a8ff6]
    3: /usr/bin/X(main+0x27b) [0x8076ceb]
    4: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d70050]
    5: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    The driver seems to work fine...but what about that error?

    Thanks for your efforts in making this hardware work under linux

  10. #10
    Join Date
    Oct 2007
    Posts
    1,187

    Default

    spidernik84, I got the exact same thing on my integrated X1250 and the driver didn't work for me. Someone in the RadeonHD IRC told me to try Option "NoRandR" "True" in my xorg.conf device section. That cleared up the error, but now it's complaining about not being able to detect my monitor. *sigh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •