Phoronix: When Open-Source Graphics Drivers Break

This morning I wrote about the troublesome experience of Intel Sandy Bridge graphics under Ubuntu 11.04 as the packages found in the Natty repository are outdated and contain only the initial "SNB" support. In the mainline upstream code, Sandy Bridge is supported much better, offers faster performance, and possesses other new features (e.g. VA-API encode), except in the past week the Intel SNB Linux code temporarily broke hard...

http://www.phoronix.com/vr.php?view=OTQ1OQ