I'm trying to install the latest Catalyst 11.5 on Ubuntu 11.04 and holy fuck is it hard!

The last Ubuntu version I used for an extended period of time was 6.10, but now 11.04 won me over once again. The problem is installing the Catalyst drivers. In openSUSE it's just a matter of running the installer and generating the suse package. Works like a charm. Not in Ubuntu though.

First I tried to use the "Additional drivers" program, and that did install fglrx, but not the CCC. I also don't want to keep the same old version as newer versions come out, so I tried going the manual route. The first problem I encountered was that the installer ran, decompress its files and then immediately after decompressing all the files it would delete the temp folder and terminate itself without a single message on what's going on. No GUI, nothing. I then discovered the --buildpkg argument and that seemed to work, as 3 new .deb files appeared. I installed those packages successfuly, but aticonfig is not in the path. I found it on the /usr/lib/fglrx/bin directory and so I tried running it from there resulting in this error:

Code:
Unable to open /etc/ati/control, please reinstall the driver.
/usr/lib/fglrx/bin/aticonfig: No supported adapters detected
The /etc/ati directory doesn't even exist. I have all the dependencies mentioned in the unofficial ati/amd wiki and still it doesn't work.

I'm a moderately knowledgeable linux user, and have always managed to install these kind of things without resorting to any forums, but now I'm lost. No wonder so many people complain about Catalyst. I could never understand why since in openSUSE everything just worked flawlessly. Wasn't Ubuntu supposed to be the most user-friendly distro out there?...

So, in short, if someone can point me to an installation guide that does work or have any other tips I'm all ears.