Myth II: Soulblighter has gotten its fair share of updates for Windows and Mac operating systems throughout the years. The Linux version (1.3e) ported by Loki Software has been outdated and is not compatible with the latest version (1.7.2) of the Windows and Mac builds for the game. If anyone is interested in helping beta test the Myth II v1.7.2 Linux build go to these Myth related forums and reply to that thread.

Keep in mind, you still need a full installation of the game to be able to run the updated Linux version being tested.