Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Open source drivers force vsync for everything 3D - why?

  1. #11

    Default

    Quote Originally Posted by DanL View Post
    Code:
    Option "SwapbuffersWait" "boolean"

    Use driconf and look under performance tab.
    I did that, but there is still vsync. Is it because of Unity? Vsync is turned off in compiz settings.

  2. #12

    Default

    *bump* I am back using open source drivers in Ubuntu 11.04 temporarily

    Here is my .drirc:

    Code:
    <driconf>
        <device screen="0" driver="r600">
            <application name="Default">
                <option name="fthrottle_mode" value="2" />
                <option name="vblank_mode" value="1" />
                <option name="allow_large_textures" value="1" />
            </application>
            <application name="warsow" executable="/home/myname/warsow/warsow">
                <option name="fthrottle_mode" value="2" />
                <option name="vblank_mode" value="0" />
            </application>
        </device>
    </driconf>
    Frames per second in Warsow is still locked at 60

  3. #13

    Default

    Quote Originally Posted by Melcar View Post
    For sync_vblank use either driconf, although I then had to configure the .drirc file it creates in my home directory and change the "driver" entry to dri2 instead of the r300 it uses (but amusingly enough that doesn't seem to work with Narwhal ).
    Alright, I just froze everything, not even REISUB saved me.

    *gives up on gaming with open source drivers for another 10 years*

  4. #14
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Ubuntu 11.04 is still using 7.10. The difference between r600g in 7.10 and (what will be released as) 7.11 is like night and day. Very much worth the effort to grab from git or by using some unofficial packages.

    You still need to manually edit drirc:
    Code:
    <driconf>
       <device screen="0" driver="dri2">
          <application name="Default">
              <option name="vblank_mode" value="0" />
          </application>
        </device>
    </driconf>

  5. #15

    Default

    I added this ppa:
    Code:
    ppa:oibaf/graphics-drivers
    Described here: http://phoronix.com/forums/showthrea...aphics-Drivers

    I don't know what driver version I now have, but vsync issues are gone! I didn't even have to run driconf and disable it there.
    Unfortunately Warsow can't achieve stable 125 fps yet, even at 640x480 resolution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •