Results 1 to 9 of 9

Thread: select ati card in hybrid setup

Hybrid View

  1. #1
    Join Date
    Jun 2011
    Posts
    3

    Default select ati card in hybrid setup

    Hello,

    I have a hp pavilion dv6-6093ex which has i5 2410m CPU and ati 6740m GPU, so it's a hybrid graphics laptop. Since I bought it almost a month now and I am trying to enable the ati card but with no success.

    I am running openSuSE 11.4 64bit with kernel 2.6.39-30-vanilla because the stock kernel does not have vga_switchroo (or I could not find it). I tried vga_switchroo after being in init 3 then issue:
    PHP Code:
    echo "DDIS" >> /sys/kernel/debug/vgaswitchroo/switch 
    but the computer hangs and I have to hold power button to shut it down.

    I also tried fglrx 11.5 but it says no supported adapter exists, so my only hope is to enable vga_switchroo. Is there a way to use the ati card in my system.

    Does this card, ati 6740m, exist? because in Windows it says it's 6770m.

    Thank in advance
    Last edited by amaj1407; 06-03-2011 at 04:43 PM.

  2. #2
    Join Date
    Jun 2011
    Posts
    3

    Default Xorg version

    I forgot to mention that my Xorg version is 1.9.3.

  3. #3
    Join Date
    May 2011
    Posts
    353

    Default

    Radeon HD 6730M, 6750M and 6770M exist but no 6740 according to the AMD/ATI GPU list on Wikipedia. Anyway, all 66xxM/67xxM cards are quite the same, based on the same Turks chip, so it should not matter which of them you're using.

    Your laptop's BIOS may have an option, often named Windows XP mode, to use the ATI only.

  4. #4
    Join Date
    Jun 2011
    Posts
    3

    Default

    Thank you albert,
    Unfortunately the BIOS does not have such an option. I asked about the existence of 6740m because Catalyst on Win tells it's a 6770m and even HP web site tells so, http://h10010.www1.hp.com/wwpc/me/en...4-5068478.html. Could this, that linux identify the card as 6740m, be the problem. If so, can I trick linux to see the card as 6770m

  5. #5
    Join Date
    Jun 2011
    Posts
    1

    Default Same Problem

    I have the same problem. Unfortunately the HP BIOS has no option to turn off the Intel Card. Anyone having an idea?
    System: HP dv6-6008eg with ATI 6770M HD
    Gentoo Linux

    Never again an HP Laptop. It is always a pain to get those running under Linux

  6. #6
    Join Date
    Feb 2011
    Posts
    11

    Default

    If you use Ubuntu, downgrading all to 10.10 (2.6.35) and using 11.5 seems to me the most "stable" configurations. Stable here means that you will get the login screen after 2 or 3 X restarts in 1-2 of 3 times, and blinking caps-lock or no X the others, but once you are able to get the X, it seems not to crash so much.
    Apart of the BIOS option, I would suggest HP to put the power-down button in a more handy position, near the F or the J in the keyboard, in order not to have to take the yous hands out of keyboard when resetting... For improving productivity, i mean...

  7. #7
    Join Date
    May 2011
    Posts
    353

    Default

    Modern HP laptops are never a real problem with Linux, only the ones with hybrid graphics, and the ones with Broadcom wireless chips. And many of their laptops use none of these 2 things.
    This is not limited to HP: any laptop using hybrid graphics has problems on Linux.

    Linux' support for hybrid graphics is bad. That's the problem. It is not HP.
    When Ubuntu 12.10 will start shipping Wayland, I think that the hybrid graphics problems will be solved by then. At least in Ubuntu 11.10 there will be a program for switching between 2 X servers, where 1 is running on the Intel and 1 on an NVidia (don't know when ATI support will come, but when NVidia works it should not be too difficult).
    Last edited by AlbertP; 06-06-2011 at 11:37 AM.

  8. #8
    Join Date
    May 2011
    Posts
    7

    Default

    Quote Originally Posted by amaj1407 View Post
    I also tried fglrx 11.5 but it says no supported adapter exists
    Don't stop there : aticonfig is not working on my system, but using this very simple /etc/X11/xorg.conf does make X work perfectly :

    Section "Device"
    Identifier "ATI"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •