Results 1 to 7 of 7

Thread: Getting "no signal" when I try using fglrx driver

  1. #1

    Default Getting "no signal" when I try using fglrx driver

    I'm currently running a fresh install of Slackware 12, and am trying to get the ATI proprietary drivers to work.

    I've followed the instructions for installing the drivers as per this post,
    http://www.linuxquestions.org/questi....4#post2866487

    However, whenever I run 'startx' my monitor just blinks and then says 'no signal' Does anybody know why this might be?

    Information:
    Kernel: 2.6.21.5-smp
    Xorg: 7.1
    Video Card: Sapphire Radeon X800 GTO
    xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "Simple Layout"
    	Screen      0  "Screen[0]" 0 0
    	InputDevice    "Mouse1" "CorePointer"
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        RgbPath     "/usr/share/X11/rgb"
        FontPath   "/usr/share/fonts/local/"
        FontPath   "/usr/share/fonts/misc/"
        FontPath   "/usr/share/fonts/OTF/"
        FontPath   "/usr/share/fonts/TTF/"
        FontPath   "/usr/share/fonts/Type1/"
        FontPath   "/usr/share/fonts/CID/"
        FontPath   "/usr/share/fonts/Speedo/"
        FontPath   "/usr/share/fonts/75dpi/:unscaled"
        FontPath   "/usr/share/fonts/100dpi/:unscaled"
        FontPath   "/usr/share/fonts/75dpi/"
        FontPath   "/usr/share/fonts/100dpi/"
        FontPath   "/usr/share/fonts/cyrillic/"
    EndSection
    
    Section "Module"
    	Load  "dbe"  	# Double buffer extension
    	SubSection "extmod"
    		Option	    "omit xfree86-dga"   # don't initialise the DGA extension
    	EndSubSection
    	Load  "type1"
    	Load  "freetype"
    	Load  "speedo"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse1"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/mouse"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Buttons" "5"
    EndSection
    
    Section "Monitor"
    	Identifier   "lulzwut"
    	Option	     "VendorName" "ATI Proprietary Driver"
    	Option	     "ModelName" "Generic Autodetecting Monitor"
    	DisplaySize  430   270	
    
    	HorizSync    31.0 - 81.0
    	VertRefresh  56.0 - 76.0
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "Device[0]"
    	Driver      "radeon"
    #	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option      "MergedFB" "false"
    
    	Option	    "AGPMode"  "8"
    	Option	    "AGPFastWrite" "true"
    EndSection
    
    Section "Screen"
    	Identifier "Screen[0]"
    	Device     "Device[0]"
    	Monitor    "lulzwut"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1024x768" "800x600" "640x480" "1280x800" "1280x1024" "1600x1050"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode         0666
    EndSection
    Last edited by jamespenguin; 09-30-2007 at 02:37 PM.

  2. #2
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    You're still using the radeon driver.
    Code:
    	Driver      "radeon"
    Change it to
    Code:
    	Driver      "fglrx"
    Or run aticonfig --initial.

    You most likely get a blank screen because of AGPFastWrite (it doesn't affect fglrx).

    Read the instructions carefully next time.

  3. #3

    Default

    Oh yeah, I probably should have mentioned that I'm using the radeon drivers right now since fglrx isn't working. /me modifies previous post.

  4. #4
    Join Date
    Feb 2007
    Posts
    9

    Default

    I am also getting no signal from the fglrx driver. Ever since I upgraded to Slackware 12 with my X800XT AIW AGP card I cannot get fglrx to work on my single head LCD Widescreen monitor (1680x1050) or any other monitor (including my old CRT).

    I tried the old method of just running the shell script, and even running the script followed by installing the packages created using --buildpkg Slackware/All. I used the aticonfig --initial -f.

    When I startx, I get "Entering Digital Power saving mode" and a blank screen with no active signal (monitor light is orange instead of blue). I end up having to CTRL-ALT-BS, then CTRL-ALT-DEL to reboot the PC as switching to a terminal shows nothing too (like the card output gets completely disabled).

    Right now only the Radeon driver is working, but the 3D is terrible unless drawing flat non textured objects (it seems textures are giving this driver grief).

    If anyone knows the exact steps to get the driver working on Slackware 12 using a AGP card I would appreciate the help!

    Thanks,
    Peter

  5. #5
    Join Date
    Sep 2006
    Location
    PL
    Posts
    916

    Default

    Right now only the Radeon driver is working, but the 3D is terrible unless drawing flat non textured objects (it seems textures are giving this driver grief).
    you have bad opengl/drm module config. i can play darkplaces just fine on mere x300se using mesa and opensource drivers.

    that happens if you use opensource 2d driver and try to use 3d via fglrx opengl library.

  6. #6
    Join Date
    Feb 2007
    Posts
    9

    Default

    I appreciate your comment on you running darkplaces (I don't know what that is), I have no such problem running basic things like glxgears and opengl screen savers including the whales. I tried running UT2004 and it runs smooth in some places then runs bad in others. Doom3 and Quake4 are hopeless as well as GoogleEarth which only ran fine when fglrx was working.

    I'm not sure if I do have a broken opengl/drm, but in case I do, how should I fix it (I completely removed fglrx and any reference to it and re-installed the mesa libraries, glxinfo shows acceleration is on).

    Anyway, back to the point. I want the FGLRX driver to work on my system. If anyone knows the reason why I am getting no signal from this driver I would really like to know what is wrong and get it working again.

    Thanks,
    Peter

  7. #7
    Join Date
    Aug 2007
    Posts
    6,674

    Default

    Sometimes it helps to use the other connector (maybe thru an adapter).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •