Results 1 to 2 of 2

Thread: Ubuntu 11.4 + Radeon HD 5850 + Catalyst 11.5 + Dual Head = Flickering!

  1. #1
    Join Date
    Jun 2011
    Location
    New Jersey
    Posts
    2

    Default Ubuntu 11.4 + Radeon HD 5850 + Catalyst 11.5 + Dual Head = Flickering!

    I'm having a great deal of difficulty making the latest Catalyst/fglrx drivers usable on my Ubuntu Natty 11.4 dual-head workstation. I've tried it with the Ubuntu-packaged drivers, r8.840, and by following the directions to build fglrx from the latest drivers, r.8.850. In both cases I was able to get Xorg/KDE to run, using aticonfig and a little hand-tweaking as necessary. However, no matter what I did, my 2nd monitor would have terrible flickering, making it very difficult to use. With a single monitor in place, no issues. With the OSS radeon drivers, no problem. With the old nVidia 8400GS card that I used to use, no problem (just slow!) I just can't get the Catalyst drivers to drive two monitors in a stable, non-headache-inducing way.

    This sounds a lot like similar issues that Windows users have reported with Cypress cards and dual-head flickering. In their cases, the issue had to do with idle clock rates that were too low to handle two monitors without flicker. However, I can't find anything in the aticonfig settings to adjust idle clocks, only peak clocks.

    lspci:
    Code:
    01:00.0 VGA compatible controller: ATI Technologies Inc Cypress [Radeon HD 5800 Series] (prog-if 00 [VGA controller])
            Subsystem: Giga-byte Technology Device 21e4
            Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
            Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Note that I tried this with and without Xinerama, with and without XRandR 1.2 enabled, and with and without the --dtop line. No combination fixed the flicker. Here's a sample of my final attempt before giving up and going back to OSS Radeon drivers.

    aticonfig commands, final attempt:
    Code:
    sudo aticonfig --initial=dual-head --screen-layout=right --xinerama=on
    sudo aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
    sudo aticonfig --dtop=horizontal --overlay-on=1
    resulting xorg.conf:
    Code:
    Section "ServerLayout"
            Identifier     "Layout0"
            Screen      0  "aticonfig-Screen[0]-0" 0 0
            Screen         "aticonfig-Screen[0]-1" RightOf "aticonfig-Screen[0]-0"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "ServerFlags"
            Option      "Xinerama" "on"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-1"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "UseFastTLS" "0"
            Option      "DesktopSetup" "horizontal"
            Option      "OverlayOnCRTC2" "1"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]-1"
            Driver      "fglrx"
            BusID       "PCI:1:0:0"
            Screen      1
    EndSection
    
    Section "Screen"
            Identifier "Screen0"
            Device     "radeon0"
            Monitor    "VGA1"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "Screen1"
            Device     "radeon0"
            Monitor    "VGA0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]-1"
            Device     "aticonfig-Device[0]-1"
            Monitor    "aticonfig-Monitor[0]-1"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Extensions"
            Option      "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Jun 2011
    Location
    New Jersey
    Posts
    2

    Default

    Update: it's the idle clock speeds. If I load the GPU sufficiently to get the clock speeds to shift from idle to peak, the flicker goes away.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •