Page 6 of 6 FirstFirst ... 456
Results 51 to 54 of 54

Thread: The Linux Kernel Power Problems On Older Desktop Hardware

  1. #51
    Join Date
    Feb 2007
    Posts
    87

    Default

    Quote Originally Posted by sLinkAge View Post
    Well just installed gentoo on my brand new laptop
    ( i7-2630QM, 8gb of ram, 7200rpm 640 gb, amd 6770m 1gb gddr5 )

    with every power management option I can think of, on idle I get 2.6 wakeups pre second in intervals of 45 seconds.

    kernel is 2.6.39-pf2.

    I really can't see the problem ( at least not on my system ).
    what power management options do you use? can you list them for us?

    I have an nvidia chip and the driver itself causes more wakeups than your entire system (even with the on-demand vblank)

  2. #52
    Join Date
    Jun 2011
    Posts
    2

    Default

    Quote Originally Posted by ioannis View Post
    what power management options do you use? can you list them for us?

    I have an nvidia chip and the driver itself causes more wakeups than your entire system (even with the on-demand vblank)
    Well,

    first of all, on boot I call acpi_call and turn off the radeon card , on linux the intel 3000 is more than I need.

    also on startup I have this script which I run :

    Code:
    for x in $(ls /sys/class/scsi_host/ )
     do
    	echo min_power > /sys/class/scsi_host/${x}/link_power_management_policy
     done
    echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
    echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
    after that I use a script I found on the net ( this mimics the powertop behavior )

    Code:
    cd /sys/devices
    find pci* -name "control" -exec /etc/local.d/help_script.sh {} \;
    When the help_script.sh is this :
    Code:
    #!/bin/bash
    
    file=$1
    
    if [[ "$file" =~ 'power' ]]
    then
      echo "$file"
      echo "auto" > "$file"
      echo "Done."
    fi
    The thing is, after this script runs, everything works fine except my lan card, so I set it back to on with this command :

    Code:
    echo on > /sys/devices/pci0000\:00/0000\:00\:1c.0/power/control
    If you want I can post my .config file so you can see how I've built the kernel.

  3. #53

  4. #54
    Join Date
    Feb 2007
    Posts
    87

    Default

    Quote Originally Posted by sLinkAge View Post
    Well,

    first of all, on boot I call acpi_call and turn off the radeon card , on linux the intel 3000 is more than I need.

    also on startup I have this script which I run :

    Code:
    for x in $(ls /sys/class/scsi_host/ )
     do
    	echo min_power > /sys/class/scsi_host/${x}/link_power_management_policy
     done
    echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
    echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
    after that I use a script I found on the net ( this mimics the powertop behavior )

    Code:
    cd /sys/devices
    find pci* -name "control" -exec /etc/local.d/help_script.sh {} \;
    When the help_script.sh is this :
    Code:
    #!/bin/bash
    
    file=$1
    
    if [[ "$file" =~ 'power' ]]
    then
      echo "$file"
      echo "auto" > "$file"
      echo "Done."
    fi
    The thing is, after this script runs, everything works fine except my lan card, so I set it back to on with this command :

    Code:
    echo on > /sys/devices/pci0000\:00/0000\:00\:1c.0/power/control
    If you want I can post my .config file so you can see how I've built the kernel.

    Thanks sLinkAge. I'll give those a try

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •