Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE SC 4.6.3 'slow' with fglrx 11.6

  1. #1
    Join Date
    Jan 2009
    Posts
    515

    Default KDE SC 4.6.3 'slow' with fglrx 11.6

    Hi.

    I am considering using KDE SC as my main desktop environment instead of Gnome 3. Mainly because KDE SC seems quite stable and I really like the look of it.

    I do have some issues remaining before taking the jump.
    Windows minimizing / maximizing seems a bit sluggish / slow. Its not super slow, but the feel of it is a lot worse than with compiz.
    Scrolling in firefox is slow.
    Resizing windows is slow.

    Does anyone see the same kwin performance issues?
    Do anyone know how to improve the performance?

    Unfortunately I can not use the oss drivers, due to lack of prober powermanagement. But I am still interested to hear if those are better.

    I did try to change the QT backend to OpenGL, but that resulted in a corrupted screen.

    My system:
    Archlinux - latest updates.
    Fglrx 11.6 using my hd4650 card.

    I hope to find a solution to this, so I can use KDE.

  2. #2
    Join Date
    Mar 2011
    Posts
    38

    Smile

    >>I do have some issues remaining before taking the jump.
    Windows minimizing / maximizing seems a bit sluggish / slow. Its not super slow, but the feel of it is a lot worse than with compiz.
    <<

    try bumping up kwin refresh:
    kwriteconfig --file kwinrc --group Compositing --key RefreshRate 120

    ..also the 'Blur' desktop effect is quite slow, disable it.

    >>Scrolling in firefox is slow.<<

    try disabling smooth scrolling in firefox

    >>Resizing windows is slow.<<

    disable 'window redraw while sizing window' KDE config option

    HTH

  3. #3
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,779

    Default

    Quote Originally Posted by slojam View Post
    >>I do have some issues remaining before taking the jump.
    Windows minimizing / maximizing seems a bit sluggish / slow. Its not super slow, but the feel of it is a lot worse than with compiz.
    <<

    try bumping up kwin refresh:
    kwriteconfig --file kwinrc --group Compositing --key RefreshRate 120

    ..also the 'Blur' desktop effect is quite slow, disable it.

    >>Scrolling in firefox is slow.<<

    try disabling smooth scrolling in firefox

    >>Resizing windows is slow.<<

    disable 'window redraw while sizing window' KDE config option

    HTH
    Q: I have a headache.
    A: Cut off your head.

  4. #4
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    Few tips for getting smooth desktop effects in KDE :

    1) Disable blur effect in System settings>Desktop effects>All effects

    2) Press Alt+F2 and type oxygen-settings. Then go to "animations" tab and uncheck "enable animations". Also under "Window decorations" uncheck "enable animations".

    3) System settings>Application appearance>Style>Fine tuning tab. Choose "Low display resolution and low CPU"

    4) Go to System Settings>Desktop effects>Advaced and uncheck "Use Vsync "

    After these tweaks my effects are super smooth. My card is Mobility radeon hd 2400 with catalyst 11.5 on Kubuntu 11.04.
    However rendering of windows, rendering window contents, resizing windows isn't fast. Then I switched to raster graphics system and miracle happened. Everything is rendered super fast now. The easiest way to turn on raster is via KCM in system settings. You can install KCM from here: http://kde-apps.org/content/show.php...content=129817

    I hope this helps

  5. #5
    Join Date
    Jan 2009
    Posts
    515

    Default

    Thanks for your suggestions guys. Well what actually helped a lot, was installing KDE SC 4.7 RC 2 and then disable OpenGL 2 shaders. What a performance boost with catalyst!
    I can't see any difference between using GL 2 shaders or not, but the performance is great not using them! Even blur works smooth and nice.

    Maybe its time to stick with KDE

  6. #6
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    There is a Kwin effect which solves all resizing problems, "resize window". Instead of redrawing windows contents it scales a texture and only when you release it you get the real, updated window. It's quite an effective, simple and elegant solution.

  7. #7
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,779

    Default

    Quote Originally Posted by yotambien View Post
    There is a Kwin effect which solves all resizing problems, "resize window". Instead of redrawing windows contents it scales a texture and only when you release it you get the real, updated window. It's quite an effective, simple and elegant solution.
    No, it's an ugly as hell solution where you have no idea what the application looks like at the new sizes. As I wrote elsewhere, when your head hurts, you don't cut it off. You try to cure it.

  8. #8
    Join Date
    Jan 2009
    Posts
    515

    Default

    Well it is better than nothing Resizing a textures seems like a good workaround for now.
    But as I wrote earlier, everything is fast with catalyst deactivating opengl 2.0 shaders. (it is somewhat fast with opengl 2.0 shaders enabled, but not as fast as without)

  9. #9
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    Well, what can I say. I like it. For sure, if that's the only problem one has with KDE, it's an acceptable solution. This doesn't mean that problems shouldn't get fixed.

  10. #10
    Join Date
    Jan 2009
    Posts
    515

    Default

    BTW. The oss driver also works fine with KDE 4.7.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •