Results 1 to 7 of 7

Thread: Can't force resolution on my LCD TV

  1. #1
    Join Date
    Jul 2011
    Posts
    4

    Default Can't force resolution on my LCD TV

    I'm working on Radeon Gigabyte 6850 OC. My default monitor resolution is 1600x900 and that's fine. My second display is Philips Tv 7404H. With fglrx (or Windows) driver supported resolutions are
    Code:
    1920x1080    1776x1000    1680x1050    1400x1050     1600x900    1360x1024    1280x1024    1440x900    1280x960   1280x768   1280x720   1024x768   1152x648   800x600   720x480   640x480
    but on radeon driver
    Code:
    1920x1080      60.0 +   50.0     24.0  
       1280x1024      60.0  
       1360x768       59.8  
       1024x768       60.0* 
       800x600        60.3  
       640x480        60.0
    I can force for example 1280x720 with cvt tool and xrandr --newmode but I have no idea how to add 1600x900@50 (/ 25) and clone my primary display 1:1. I got unsupported video format message on my TV. Any ideas?
    Thank You.

    OpenSuse 11.4, kernel-desktop-2.6.39.2-35.1.x86_64

  2. #2
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    993

    Default

    ~$ gtf 1600 900 50

    # 1600x900 @ 50.00 Hz (GTF) hsync: 46.30 kHz; pclk: 97.04 MHz
    Modeline "1600x900_50.00" 97.04 1600 1680 1848 2096 900 901 904 926 -HSync +Vsync

    xrandr --newmode "1600x900_50.00" 97.04 1600 1680 1848 2096 900 901 904 926 -HSync +Vsync

    xrandr --addmode DVI-0 1600x900_50.00

    xrandr --output DVI-0 --mode 1600x900_50.00

  3. #3
    Join Date
    Jul 2011
    Posts
    4

    Default

    Yes, I tried this but I got "Unsupported video format".

  4. #4
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    You probably need reduced blanking timings. Try cvt rather than gtf. Also, IIRC, the drm edid code does not parse all the hdmi extension blocks which is generally where the common consumer device modes live. It should be possible to port the edid hdmi extension block parsing from X to the kernel.

  5. #5
    Join Date
    Jul 2011
    Posts
    4

    Default

    I tried both: cvt and gtf. I can't use -r mode because my tv has at max 1600x900@50Hz and for reduced blanking multiply of 60 is required. Also tried Option "ExactModeTimingsDVI" "false" (I have DVI->HDMI cable but modes are not detected on hdmi->hdmi as well).

  6. #6
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    You can also just copy the modeline from fglrx or your xorg log.

  7. #7
    Join Date
    Jul 2011
    Posts
    4

    Default

    Just finished testing. Fglrx modes:
    Code:
    Modeline "1600x900_50.00"  148.50  1600 2448 2492 2640  900 1084 1089 1125 +hsync +vsync
      Modeline "1600x900_25.00"   74.25  1600 2448 2492 2640  900 1084 1089 1125 +hsync +vsync
      Modeline "1600x900_30.00"   74.18  1600 2008 2052 2200  900 1084 1089 1125 +hsync +vsync
      Modeline "1600x900_24.00"   74.18  1600 2558 2602 2750  900 1084 1089 1125 +hsync +vsync
    But none of them works with radeon driver

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •