Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 57

Thread: MLAA For Mesa Is Ready For Testing

  1. #21
    Join Date
    Oct 2008
    Posts
    3,149

    Default

    Quote Originally Posted by TheCycoONE View Post
    Using renderer: OpenGL 2.1
    Gallium 0.4 on llvmpipe: VMware, Inc.
    You're running the software renderer there, instead of the r300g driver.

  2. #22
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,128

    Default

    Quote Originally Posted by droste View Post
    that output is obviously wrong.

    Beside this error: I'm wondering if the FPS output with the sphere is really right, but the sphere shows more FPS if the window is in the lower right corner (~600FPS). In the upper left corner I get ~250FPS. Both without MLAA. With MLAA it's ~77FPS and ~74FPS so it's not that visible but still the case.
    Window position anomaly - maybe caused by your compositor?

    Timing wrong - possibly. Could also be that you use a newer irrlicht, as the title bar fps is taken from irr.

  3. #23
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,128

    Default

    Quote Originally Posted by Drago View Post
    So...this MLAA is entirely in software/shader, and not actual GPU anti-aliasing method?
    Yeah. But it's entirely on the GPU, no CPU software part.

  4. #24
    Join Date
    Jul 2011
    Posts
    6

    Default

    Irrlicht Engine version 1.7.2
    Linux 2.6.39-ARCH #1 SMP PREEMPT Mon Jun 27 21:26:22 CEST 2011 x86_64
    Using renderer: OpenGL 4.1.10834
    ATI Radeon HD 5700 Series: ATI Technologies Inc.
    OpenGL driver version is 1.2 or better.
    GLSL version: 4.1
    Loaded texture: AreaMap33
    Unsupported texture format
    Quit message received.

    Ran 204.882s, average fps 225.12, min 1

    Average on fps 1055.90, average off fps 181.66

    MLAA took on average 0.9ms

    mesa
    Version : 7.10.99.git20110706-1
    Radeon 5770

  5. #25
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    I'm also getting some really odd numbers with the latest version of the test, and this is using the binaries you provided.

  6. #26
    Join Date
    May 2010
    Posts
    123

    Default

    Quote Originally Posted by smitty3268 View Post
    You're running the software renderer there, instead of the r300g driver.
    Ops, good catch. Hopefully that explains the really broken display too. So next up is diagnosing why it didn't go with r300g. Sorry for all the noise.

  7. #27
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,128

    Default

    Okay, trying again. It's funny how llvmpipe gave me correct numbers with the previous commit; let's see if the latest improves things on real hw.

  8. #28
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Yeah, the new results seems to be okay:

    Code:
    Ran 41.635s, average fps 288.01, min 1
    
    Average on fps 130.86, average off fps 583.15
    (The first test I ran was with power_profile set to low, so quite far off the mark, sorry about that!)

  9. #29
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,128

    Default

    No, it was interesting to see how much the low profile affected the performance. Almost exactly four times worse with low.

  10. #30
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    504

    Default

    Quote Originally Posted by curaga View Post
    Window position anomaly - maybe caused by your compositor?

    Timing wrong - possibly. Could also be that you use a newer irrlicht, as the title bar fps is taken from irr.
    You were right, it was KWins fault. The average FPS is now also correct with the new version.

    Results with r600g and hd5770 (juniper):

    low: Average on fps 60.43, average off fps 312.62
    high: Average on fps 60.38, average off fps 526.58

    with MLAA on, the FPS was somehow capped at 60FPS. That's probably because SwappbuffersWait is turned on, but why isn't the FPS capped without MLAA?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •