Results 1 to 4 of 4

Thread: Fedora 15 "too old" for Mesa-git?

  1. #1
    Join Date
    Jul 2007
    Posts
    442

    Default Fedora 15 "too old" for Mesa-git?

    Fedora 15 provides DRI2 2.3 and glproto 1.4.12, whereas Mesa-git now requires DRI2 2.6 and glproto 1.4.14.

    Was it completely impossible to keep the old "swap event type" code as a "configure" option? E.g.

    Code:
    #define USE_OLD_SWAP_EVENT=1
    Or don't developers like having testers any more?

  2. #2
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,051

    Default

    I think they even discussed having that option, and decided it would be too much hassle.

  3. #3
    Join Date
    Dec 2007
    Posts
    2,357

    Default

    It's really easy to install updated dri2 and gl proto headers:
    http://cgit.freedesktop.org/xorg/proto/glproto/
    http://cgit.freedesktop.org/xorg/proto/dri2proto/

  4. #4
    Join Date
    Jul 2007
    Posts
    442

    Default I'm sure it's easy, but...

    Quote Originally Posted by agd5f View Post
    It's really easy to install updated dri2 and gl proto headers:
    http://cgit.freedesktop.org/xorg/proto/glproto/
    http://cgit.freedesktop.org/xorg/proto/dri2proto/
    The headers are supposed to reflect the binaries installed on the system, aren't they? If I installed updated headers then surely they'd just be advertising functionality which simply isn't available in the libdri2.so or libglx.so modules that ship with F15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •