Results 1 to 4 of 4

Thread: Switching between integrated Radeon 4200 and discrete Radeon 6600M

  1. #1
    Join Date
    Jul 2011
    Posts
    41

    Question Switching between integrated Radeon 4200 and discrete Radeon 6600M

    Hello, all!

    Sorry for my English!

    I have a problem with switching between integrated Radeon 4200 and discrete Radeon 6600M (actually Radeon 6650M) on HP Pavilion dv6-6030er. In Win7 it is working properly, but in Debian GNU/Linux (testing) it doesn't work. Installed fglrx 11.6 (from unstable repository). There is an option in ATI Catalyst Control Center (amdccle) to switch between cards. It can be changed (and it asks to reboot), but after reboot or Xorg restart it returns back.

    My lspci -nn: http://pastebin.com/VBWa10mt

    My xorg.conf (created with aticonfig --initial): http://pastebin.com/ZkezxQ8H

    My lshw: http://pastebin.com/HCV6H9Um

    What I can try to do?

  2. #2
    Join Date
    Jul 2011
    Posts
    41

    Default

    Also I tried to change

    BusID "PCI:1:5:0"
    in my xorg.conf to

    BusID "PCI:2:0:0"
    (see my lspci -nn output). But after that I got segmentation fault: http://pastebin.com/6psjDc8S

  3. #3
    Join Date
    Jul 2011
    Posts
    41

    Default

    Quote Originally Posted by dogsleg View Post
    Sorry, this is my Xorg.0.log with default xorg.conf.

  4. #4
    Join Date
    Jul 2011
    Posts
    41

    Default

    Yeah! It is working with fglrx 11.7. But in 11.7 most (every?) 32-bit 3D applications segfault.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •