As the U mainline kernel work fine with Debian after a little dpkg-deb and sed magic it would be nice when the depends would be correct and do not need hacking. Also Launchpad should support Debian Squeeze at least for PPA.