Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Starcraft 2 on Fedora 15 with FOSS Radeon Driver

  1. #11
    Join Date
    Feb 2009
    Posts
    45

    Default

    Quote Originally Posted by letharion View Post
    Looking at the wine output, it looks like wine doesn't find a GPU at all, and maybe SC2 is just "defaulting" to the oldest GPU it knows about.
    Probably. What driver / hardware are you actually using? This sounds like the kind of thing that would happen if you either don't have properly installed 32-bit GL drivers, or are using a fairly old Mesa version.

  2. #12
    Join Date
    May 2011
    Posts
    18

    Default

    Quote Originally Posted by Henri View Post
    Probably. What driver / hardware are you actually using? This sounds like the kind of thing that would happen if you either don't have properly installed 32-bit GL drivers, or are using a fairly old Mesa version.
    I'm xf86-video-ati and mesa from git as of yesterday. I do believe I have the 32-bit opengl libs installed. Based on your feedback, I tried another game, and have similar problems. My problem likely has nothing at all to do with SC2, and I submitted a new thread instead of hijacking this one. Awaiting moderation.

  3. #13
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    910

    Default

    This may give you some information about your GPU:
    Code:
    # lspci | grep VGA
    If you're really dealing with an Nvidia card then xf86-video-ati is obviously not for you.
    Try xf86-video-nouveau or the legacy blob (in case of an 5500) instead.
    Also, make sure mesa contains the specific bits for your card.

  4. #14
    Join Date
    May 2011
    Posts
    18

    Default

    Quote Originally Posted by entropy View Post
    This may give you some information about your GPU:
    Code:
    # lspci | grep VGA
    If you're really dealing with an Nvidia card then xf86-video-ati is obviously not for you.
    Try xf86-video-nouveau or the legacy blob (in case of an 5500) instead.
    Also, make sure mesa contains the specific bits for your card.
    Thanks, but I don't have an nvidia card. Not sure why SC2 says otherwise. My post with more info has emerged here: http://phoronix.com/forums/showthrea...ames-with-Wine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •