Results 1 to 5 of 5

Thread: Asus 1015B HD Videos VA API on Debian + XFCE (Xubuntu )

  1. #1
    Join Date
    Jul 2011
    Posts
    3

    Default Asus 1015B HD Videos VA API on Debian + XFCE (Xubuntu )

    Hi

    I installed today xubuntu on my new Asus eeePC 1015B
    and have only this one mayor issue left.
    (Sorry for the double post the first one was in the wrong section)

    Could not get the HD playback wokring right now.
    in the 1015B there is a ATI HD6250 build in

    I installed the properitay driver 11.7 Catalyst.
    (followed the Ubuntu Natty Installation Guide from http://wiki.cchtml.com/index.php/Ubu...allation_Guide)

    Then I installed libva1 from PPA: https://launchpad.net/~dtl131/+archive/catalysthacks
    and its modified vlc player. Also installed http://www.splitted-desktop.com/~gbe...8.0-1_i386.deb

    When playing a Video my CPU goes to 100 so I guess the hardware acceleration does not work..

    Code:
    vlc --ffmpeg-hw
    VLC media player 1.1.9 The Luggage (revision exported)
    Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
    Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
    [0x8845914] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    Blocked: call to setlocale(6, "")
    Blocked: call to setenv("ORBIT_SOCKETDIR", "/tmp/orbit-cmp", 1)
    Warning: call to srand(1312055660)
    Warning: call to rand()
    Blocked: call to setlocale(6, "")
    
    (process:5447): Gtk-WARNING **: Locale not supported by C library.
    	Using the fallback 'C' locale.
    Warning: call to rand()
    Warning: call to rand()
    Warning: call to rand()
    Warning: call to rand()
    libva: libva version 0.32.0-sds2
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/va/drivers/fglrx_drv_video.so
    libva: va_openDriver() returns 0
    xvba_video: XVBA_GetSurface(): status 2
    [0x8cc793c] avcodec decoder: Using VA API version 0.32 for hardware decoding.
    [0x88e0544] signals interface error: signal 17 overriden (0x3af14c0)
    [0x88e0544] signals interface error:  /usr/lib/libQtCore.so.4(?)[(nil)]
    number of reference frames exceeds max (probably corrupt input), discarding one
    number of reference frames exceeds max (probably corrupt input), discarding one
    Xorg.log has no errors in it.
    VLC has its option set to use Hardware acceleration.
    What can I do?
    Motr Details will be attatched as so as possible

  2. #2
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    vlc does not work correctly with vaapi. use mplayer vaapi or xbmc.

  3. #3
    Join Date
    Jul 2011
    Posts
    3

    Default

    Thx

    I was trying to build mplayer from source and get this : ERROR: you need VA API headers for this project
    Iam not sure where to get the headers from for further ./configure

    xmbc looks very nice but dont you thinkt it will be OVERKILL for my small eeepc ? just thinking of energy efficienc

  4. #4
    Join Date
    Jul 2011
    Posts
    3

    Default

    Here are some more infos about my system

    vainfo
    Code:
    libva: libva version 0.32.0-sds2
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/va/drivers/fglrx_drv_video.so
    libva: va_openDriver() returns 0
    vainfo: VA API version: 0.32
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.8.0
    vainfo: Supported profile and entrypoints
          VAProfileH264High               :	VAEntrypointVLD
          VAProfileVC1Advanced            :	VAEntrypointVLD
    Thats how I check if my gpu is redendering the move or by cpu
    Code:
    watch -n 1 aticonfig --odgc 
    
    Default Adapter - AMD Radeon HD 6200 series Graphics 
                                Core (MHz)    Memory (MHz)
               Current Clocks :    276           533
                 Current Peak :    276           533
      Configurable Peak Range : [276-276]     [533-533]
                     GPU load :    0%
    and a detailed output of what happens when I use vlc

    http://pastebin.com/jL2cKctN
    Last edited by helixum; 07-31-2011 at 06:56 AM.

  5. #5
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    xbmc is definitely the best choice. But of course you need libva headers if you want to build vaapi support for it. the problem with mplayer is a bit different, it does not detect libva due to a bug in the libva debian package, so you have to force vaapi support or patch it. Well i do that with my script, but it also updates libva, so maybe just force vaapi if you dont want to update libva.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •