Page 1 of 3 123 LastLast
Results 1 to 10 of 56

Thread: Sampling info about that mouse freeze bug

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Posts
    519

    Default Sampling info about that mouse freeze bug

    Ticket on the unofficial bugzilla: http://ati.cchtml.com/show_bug.cgi?id=141

    I'd like to make a thread a bit more structured than the comments gathered here and there on this forum, in order to pin down possible causes.

    Could anyone using fglrx in here please post the following info:
    Affected by the bug: Yes/No
    Graphics card:
    Number of displays:
    Distribution (name, version, architecture):
    Desktop environment:
    Compositing: On/Off
    fglrx version(s) I've used on that distribution, with that bug:
    fglrx version(s) I've used on that distribution, without that bug:
    ATI Catalyst Control Center settings:
    Things I've tried to solved it (if affected):
    Affected by the bug: No
    Graphics card: HD4670 512MB
    Number of displays: 1
    Distribution (name, version, architecture): openSUSE 11.4 64bit
    Desktop environment: KDE
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: none
    fglrx version(s) I've used on that distribution, without that bug: 11.3 through 11.7 (from AMD's website)
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): obviously none, though my first thought would be to try using SWCursor
    Last edited by PsynoKhi0; 07-30-2011 at 06:37 PM.

  2. #2

    Default

    Affected by the bug: Yes
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 11.04 64bit
    Desktop environment: Gnome
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.7
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): SWCursor will fix it, but it doesn't work very well, the cursor disappears, playing games you can't even see the cursor... Tried turning v-sync off, tear free off, doesn't fix it.
    Last edited by tcv90; 07-30-2011 at 06:56 PM.

  3. #3
    Join Date
    Aug 2011
    Posts
    37

    Default

    Quote Originally Posted by tcv90 View Post
    Affected by the bug: Yes
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 11.04 64bit
    Desktop environment: Gnome
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.7
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): SWCursor will fix it, but it doesn't work very well, the cursor disappears, playing games you can't even see the cursor... Tried turning v-sync off, tear free off, doesn't fix it.
    Mine is very similar:
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 10.10 64-bit, Ubuntu 11.04 64bit
    Desktop environment: Gnome 2.x, Unity
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.6
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default

    I did not install the drivers outside of X. I downloaded the ATI drivers and then followed these steps in Ubuntu:
    1. Open terminal
    2. sudo bash (enter password)
    3. cd /home/(my account)/Downloads
    4. chmod 744 ati-driver-installer-11-6-x86.x86_64.run
    5. ./ati-driver-installer-11-6-x86.x86_64.run
    Follow prompts, restart.

    If anyone can seriously suggest that installing the new driver outside of X is better, I'll give it a go. I'm not sure how to shut down X in Ubuntu. In Debian I go to a tty and do "init 3". Anyone know the Ubuntu equivalent off hand?

    I didn't try 11.7 because I see no reason to do it when other people are still reporting the bug.

  4. #4
    Join Date
    Aug 2011
    Posts
    95

    Default

    Code:
    Affected by the bug: Yes
    Graphics card: ATI HD 5750
    Number of displays: 2 or 1
    Distribution (name, version, architecture): Fedora 15; kernel 2.6.38 - 3.0
    Desktop environment: XFCE
    Compositing: On
    fglrx version(s) I've used on that distribution, with that bug: 1.5+
    fglrx version(s) I've used on that distribution, without that bug: 1.4-
    ATI Catalyst Control Center settings: default
    Things I've tried to solved it (if affected): SWCursor set to true (breaks certain games), Downgrading to 1.4
    Fortunately, RPMFusion provides a downgraded package for the Catalyst driver at 1.4.
    Unfortunately, Fedora 15 now uses Linux 3.0 as of August 4, 2011. The earliest known catalyst driver able to handle that is 1.7 which contains the bug.
    Thankfully, Fedora keeps several fallback images :3
    Last edited by computerquip; 08-05-2011 at 01:37 AM.

  5. #5
    Join Date
    Feb 2010
    Posts
    519

    Default

    For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.

  6. #6
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    @Michael_S

    NEVER use the installer without creating deb packages for anything newer than lucid. That kills the system, at least parts of it that you wont be able to switch back to oss drivers your way even when you install it correctly later.

  7. #7

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.
    Both the repo version and the one from AMD's site works fine.

  8. #8
    Join Date
    Feb 2010
    Posts
    519

    Default

    Quote Originally Posted by Michael_S View Post
    If anyone can seriously suggest that installing the new driver outside of X is better, I'll give it a go. I'm not sure how to shut down X in Ubuntu. In Debian I go to a tty and do "init 3". Anyone know the Ubuntu equivalent off hand?
    Sorry, missed that:
    Code:
    sudo service gdm stop
    Replace gdm with the appropriate session manager (kdm, lxdm...) if needed.

    Summing up so far:
    It seems to affect desktop cards based on the HD5000 and HD6000 series, on distributions shipping kernel 2.6.38 and later, with fglrx version 11.5+

    More input appreciated!
    Last edited by PsynoKhi0; 08-07-2011 at 03:10 PM.

  9. #9
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    910

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    Summing up so far:
    It seems to affect desktop cards based on the HD5000 and HD6000 series, on distributions shipping kernel 2.6.38 and later, with fglrx version 11.5+
    At least your link to the bug tracker lists a user with a Radeon HD4250.

    Nikolay 2011-08-03 17:54:26 CDT
    I have this bug too.
    Ati Radeon HD 4250
    Ubuntu 10.10
    Catalyst 11.05 - 11.07

  10. #10
    Join Date
    Aug 2009
    Posts
    87

    Default

    Affected by the bug: No
    Graphics card: HD5830
    Number of displays: 1
    Distribution (name, version, architecture): Gentoo, x86_64, 2.6.38
    Desktop environment: XFCE 4.8
    Compositing: OFF
    fglrx version(s) I've used on that distribution, without that bug: 10.6
    ATI Catalyst Control Center settings: Default (Vsync OFF)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •