Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 57

Thread: AMD Catalyst 11.8 Linux Driver Released

  1. #21
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,124

    Default

    Quote Originally Posted by chronniff View Post
    On my 5770 still the same extreme lag when scrolling chromium, and firefox maximized on my 1080p display in ubuntu 11.04. This is with tear free enabled, which really needs some performance improvements, at the very least when it comes to 2D rendering, which for non gamers is 99% of what they are using, and even gamers are probably using 2d rendering most of the time they are on there computer anyway.
    Anyone using chromium I found a workaround for the terrible scrolling lag I just described, type in about:flags into the address bar, and enable the the option: "GPU compositing on all pages". This works very well other than some very occasional very minor rendering mistakes that comes with it being an experimental feature of the browser (I'm using the dev build of chromium and it has the option, not sure how long its been there and what releases its in).

    Personally I went back to the free drivers using oibaf's ppa, which work perfectly for 95% of the tasks I ever do on this box......the experience is seriously so much less of a headeache than dealing with catalysts constantly changing issues. If dynamic power clocking worked right, there would really be no reason to ever go back to catalyst
    But you have disabled sync to vblank in Compiz have you?

  2. #22
    Join Date
    Jul 2009
    Posts
    3

    Default I'm in the same boat with my E-350 laptop

    Quote Originally Posted by bridgman View Post
    I didn't think we had a workstation (eg FirePro) product based on E-350 or any of the Fusion parts yet. Doesn't mean we don't want fglrx to work on your laptop, but it's when we say "workstation" we're talking about FirePro etc...

    I'm actually a bit surprised that suspend/resume is working with the open drivers. The feedback I had heard was more the other way round, that we had a known issue with the open drivers but that fglrx worked. Will ask around.

    I haven't had a chance to search through the unofficial bug tracker but if there isn't a similar ticket on there already it would be great if you could add one with system details. Suspend/resume is relatively more system specific than most functionality so a problem on your system may not mean the functionality is generally broken.

    One advantage that the open source drivers have had is that relatively more of the development has been done on real production systems (after launch) whereas most of the Catalyst work has to be completed well before production hardware is available. This advantage may go away a bit as we try to do the open source development work earlier and provide support closer to launch -- we'll need to figure out the best balance.
    I'm in the same boat with my E-350 Acer laptop. There is no suspend/resume with closed driver, but it works with open source driver. Unfortunately video is so bad with the open driver that I boot into Windows for any videos. I have logged the bug with Ubuntu (even though it is the same with all distro's - I have tried Mint, Mandriva, Fedora, etc), and have tried manually installing (and uninstalling) each version of Catalyst through 11.7. I even updated to latest bios. I will probably try 11.8, but I am not hopeful of it working. I have also tried all workarounds, including even the trick with debugging the sleep with the bios clock. Nothing. This will be my last laptop I buy without Linux preloaded!

  3. #23
    Join Date
    Jan 2010
    Posts
    105

    Default

    Quote Originally Posted by d2kx View Post
    But you have disabled sync to vblank in Compiz have you?
    yup, I also suspect alot of the problems are due to the version of compiz and unity that ships with ubuntu 11.04. On Previous releases catalyst worked just fine (well fine for catalyst).

  4. #24
    Join Date
    Jul 2009
    Posts
    3

    Default Even Linux Mint

    Quote Originally Posted by chronniff View Post
    yup, I also suspect alot of the problems are due to the version of compiz and unity that ships with ubuntu 11.04. On Previous releases catalyst worked just fine (well fine for catalyst).
    FYI, I switched to Linux Mint 11, which doesn't use unity. Using the compiz tray icon I have compiz switched off (using metacity). Still no suspend and resume with Catalyst and E-350 APU.

  5. #25
    Join Date
    Sep 2007
    Posts
    997

    Default

    It looks like ATI/AMD drivers are still buggy no matter whether closed or open source. Really disappointing.

    Looking at buying a $90-ish card but I don't think I can risk it with an ATI card. Regardless of what I get, I wouldn't be able to sell it to get my money back.

    I guess things are worse with mobile-based cards in which you have to worry about power management and the suspend features.

    But, two strikes against it, is uselessness for trying BSD and less performance if you ever need to use wine.

    Also, it sounds like video is another area where Nvidia, unfortunately, excels. I want to choose the open source option but performance is important to me. When one is just a general computer user, you go with what works, right? :-/

    Another area is all the desktop effects, compiz, flash use, fs/window, scrolling, tearing etc. etc. issues I read regarding ATI catalyst AND radeon drivers.

    I know Nvidia has its share but I don't know which is the worse situation.

  6. #26
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Panix View Post
    It looks like ATI/AMD drivers are still buggy no matter whether closed or open source. Really disappointing.
    do your own experiences.

    i do not have any problem with the catalyst 11.8.

  7. #27
    Join Date
    Sep 2007
    Posts
    997

    Default

    Quote Originally Posted by Qaridarium View Post
    do your own experiences.

    i do not have any problem with the catalyst 11.8.
    I can't. 'don have one.

    I'm referring to a few threads on here and some of the owners are saying what they are having problems with (video being one).

    What works, specifically?

  8. #28
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Panix View Post
    I can't. 'don have one.

    I'm referring to a few threads on here and some of the owners are saying what they are having problems with (video being one).

    What works, specifically?
    all i do works... i watch movies and i play games nativ and wine games.

    if there is a real problem i truely start a theat here at phoronix

  9. #29
    Join Date
    Aug 2009
    Posts
    87

    Default

    sticking with 11.6 until the OpenCL bug is fixed.

    to the folks bitching about suspend/resume: What suspend software are you using ? tuxonice or swsusp2 (or how is it called) ? I never had any luck with tuxonice and fglrx but swsusp2 worked without problems.

  10. #30
    Join Date
    Jan 2008
    Posts
    36

    Default I've got the same suspend errors

    I've tried 11.7 and 11.8 with a e-350 APU and I have the same suspend issue. It's bearable but... I wish AMD would get this fixed *sigh* .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •