Results 1 to 6 of 6

Thread: Mobility X1400 and radeonhd - questions

  1. #1
    Join Date
    Oct 2007
    Posts
    46

    Default Mobility X1400 and radeonhd - questions

    I've just put the RadeonHD driver on my laptop for the first time and things aren't doing badly. Two things:

    - there's a lot of noise in the video output, on the laptop panel at least. I took a screenshot and the noise does not exist there; zooming in on areas of colour reveals the noise is a constant pattern in the background. This does not happen with the fglrx driver.

    - any power saving modes? RadeonHD's power usage puts the laptop up to 24 watts versus 14 when fglrx is in its best power-saving mode. Is there a utility to set the clock speed of the chip anywhre?

    All in all a very interesting experience.

    Thanks,
    Cameron

  2. #2
    Join Date
    Sep 2007
    Posts
    128

    Default

    While I look forward to the RadeonHD overtaking binary blobs, currently it's still needs some heavy development (it's version 0.0.2 I believe), and is not ready for production use.

    The best thing to do in this case is to report these issues to the developers (RadeonHD dev's).

  3. #3
    Join Date
    Oct 2007
    Posts
    46

    Default

    Quote Originally Posted by Uchikoma View Post
    While I look forward to the RadeonHD overtaking binary blobs, currently it's still needs some heavy development (it's version 0.0.2 I believe), and is not ready for production use.

    The best thing to do in this case is to report these issues to the developers (RadeonHD dev's).
    Cool. Got a link?

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,545

    Default

    Quote Originally Posted by sastraxi View Post
    Cool. Got a link?
    radeonhd@opensuse.org is the main mailing list. Archive at lists.opensuse.org/radeonhd.

    Also, Luc pushed some changes yesterday which might help with your panel noise -- if you're not running last night's code then pulling the latest driver might help.

  5. #5
    Join Date
    Oct 2007
    Posts
    178

    Default Thinkpad Z61m X1400

    Just checked out the git repo and compiled the driver on my Thinkpad Z61m running Frugalware 'current'. Works quite nicely! Using it as I type.

    Color gradients etc seem a bit grainy compared to the fglrx driver (maybe it is not running in 24 bit after all), XV does not work with mplayer and of course there is no 3D, but it appears quite stable. Scrolling in windows and moving windows around is smooth. Playing an Xvid brings my CPU usage to 38%.

    Suspend/resume does not work automagically though and I suspect there needs to be some editing of acpi-related settings to get it going (if it works at all).

    All in all, I am pretty impressed. It is a keeper.

  6. #6

    Default

    Hi all,

    Nice to see that the radeonHD driver is coming along well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •