Installation worked flawless for me on Ubuntu Gutsy. Whitelisted fglrx in /usr/bin/compiz on line 54 (someone asked how to do it previously).

Performance is not really good. Worse than the opensource ati driver (like kirý said). Did I miss enabling some options in xorg.conf?

Greetings...