Yes, I do know that I am slow, but here is another update for the stable series of Wesnoth:

Version 1.2.7 is out and some distris did already update their repos. Those who did not update so far should do so ASAP since an important security vulnerability was fixed that did allow other clients to crash your client when being connected to the mp server. We are not sure if remove code execution would be possible, so better consider updating to the latest stable release. This bug was submitted as CVE-2007-3917.

Beside this many translations were updated, maps slightly improved and the font needed for the Japanese translation is now included in the tarball/binaries.

Since the last release I did mention in here (1.2.4) quite many things did change, but I am too lazy to list them in here so better have a look at the official changelog to get all those infos. There is an offical announcement thread in the Wesnoth forums, feel free to comment in there.

I hope that this will be the last release in the stable 1.2.x series. Of course there is also some "development branch" where all the work is going to and many improvements do happen (eg *many* new campaigns). If you want to check this stuff, either ask your package manager or get the sourcecode at the Wesnoth homepage and compile it yourself.

I hope you will enjoy this release.