Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: compiz-fusion (on Ubuntu/Gutsy) and 8.42

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Posts
    46

    Default compiz-fusion (on Ubuntu/Gutsy) and 8.42

    Hi all,

    Got the new driver compiled and all, but there's unusable display corruption when using desktop effects.
    Maybe it's using the wrong path?

    I'm just not sure...
    http://img27.picoodle.com/img/img27/...tm_c47b89c.png

  2. #2

    Default

    Do you have fglrx in your driver whitelist in /usr/bin/compiz ?

  3. #3
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,091

    Default

    Have you whitelisted fglrx in /usr/bin/compiz on Line ~50?

  4. #4
    Join Date
    Oct 2007
    Posts
    46

    Default

    Yes, I have.
    WHITELIST="nvidia intel ati radeon i810 fglrx"

  5. #5
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,091

    Default

    Is 3D working properly for you? Does "fglrxinfo" show that fglrx is used over mesa?

  6. #6

    Default

    Did you do a clean install of Gutsy or a dist-upgrade? In your xorg.conf do you have Composite and AIGLX enabled?

  7. #7
    Join Date
    Oct 2007
    Posts
    46

    Default

    3D is working properly:

    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1400
    OpenGL version string: 2.0.6958 Release

    It's a clean install of Gutsy. The old modules (8.41) were removed and the new ones were installed with module-assistant.

    I don't have composite and aiglx *disabled* - that is to say, the ServerFlags and Extensions sections are empty. compiz seems to start up just fine:

    cameron@vienna:~$ compiz
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 01:00.0 0300: 1002:7145 (prog-if 00 [VGA])
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1440x900) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: not present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    Starting emerald
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

  8. #8
    Join Date
    Oct 2007
    Posts
    46

    Default

    Just to know, is anyone else experiencing this or am I alone?

  9. #9

    Default

    Many people are experencing problems with compiz generally...we still have to understand if this is related to the new AIGLX implementation, to Compiz itself or to an unfortunate marriage

  10. #10
    Join Date
    Oct 2007
    Posts
    8

    Default

    wow, i'm actually a bit envious. b/c you at least have the driver installed correctly

    i always get MESA with the 8.42 driver even on a fresh squeaky clean install of gutsy. oddly enough the 8.40 driver worked fine using the exact same guide. anyway. if you have any ideas on THAT problem, i would love to know. sorry for changing topic.

    anyway, i know compiz part of the system now, but when i used it with XGL i manually installed it and got some extra options. might help you. here:s the code:

    sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0
    Last edited by b4sakenxx; 10-26-2007 at 01:36 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •