Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: 8.42 driver No GLXFBConfig for default depth

  1. #1
    Join Date
    Oct 2007
    Posts
    13

    Default 8.42 driver No GLXFBConfig for default depth

    Running Gutsy here. Upgraded to the new driver fine. One question I have. Should I uninstall xserver-xgl? When I do I no longer get compiz working and I get the error.

    Fatal: No GLXFBConfig for default depth, this isn't going to work.

    I tried setting the resolution to 16 but then I get the xorg thingy asking me if I want to reconfigure. Tried running from git compiling myself. Tried removing everything and reinstalling the Ubuntu compiz. Tried using Trevino's build script.

    Now I'm back to running with xgl installed. Any ideas or is this normal.

    BTW:
    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1300
    OpenGL version string: 2.0.6958 Release

    Section "Extensions"
    Option "Composite" "1"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

  2. #2
    Join Date
    Oct 2007
    Posts
    13

    Default

    Found the solution as soon as I posted this.
    I needed to whitelist fglrx in
    /etc/xdg/compiz/compiz-manager

    That fixed things.

  3. #3
    Join Date
    Sep 2007
    Posts
    7

    Default

    i use opensuse and i have the still problem:

    florin@florinsam-laptop:/etc/xdg> compiz
    compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
    compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0

    any ideeas?


    i don`t have /etc/xdg/compiz-manager. any ideeas?

  4. #4
    Join Date
    Oct 2007
    Posts
    2

    Default The same here...

    I also use OpenSuse 10.3 and got as well this error:

    Code:
    LIBGL_ALWAYS_INDIRECT=true compiz --replace
    compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
    compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0
    I adjusted /usr/bin/compiz-manager (!) to whitelist fglrx but it doesn't help.

    I put
    Code:
      Option         "AddARGBGLXVisuals" "True"
      Option         "DisableGLXRootClipping" "True"
      Option         "RenderAccel" "True"
    under the Screen section in xorg.conf (like it is recommended on many sites to avoid this problem).

    System: - Compiz 0.6.2 (0.5.2 did not work as well)
    - Ati Mobility Radeon X600

    ------
    fglrxinfo:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI MOBILITY RADEON X600
    OpenGL version string: 2.0.6958 Release
    ------
    No errors in xorg.log
    Code:
    cat /var/log/Xorg.0.log | grep "EE"
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    ------
    Some warnings during initiation of AIGLX:
    Code:
    cat /var/log/Xorg.0.log | grep "AIGLX"
    (**) Option "AIGLX" "on"
    (**) AIGLX enabled
    (WW) AIGLX: 3D driver claims to not support visual 0x23
    (WW) AIGLX: 3D driver claims to not support visual 0x24
    (WW) AIGLX: 3D driver claims to not support visual 0x25
    (WW) AIGLX: 3D driver claims to not support visual 0x26
    (WW) AIGLX: 3D driver claims to not support visual 0x27
    (WW) AIGLX: 3D driver claims to not support visual 0x28
    (WW) AIGLX: 3D driver claims to not support visual 0x29
    (WW) AIGLX: 3D driver claims to not support visual 0x2a
    (WW) AIGLX: 3D driver claims to not support visual 0x2b
    (WW) AIGLX: 3D driver claims to not support visual 0x2c
    (WW) AIGLX: 3D driver claims to not support visual 0x2d
    (WW) AIGLX: 3D driver claims to not support visual 0x2e
    (WW) AIGLX: 3D driver claims to not support visual 0x2f
    (WW) AIGLX: 3D driver claims to not support visual 0x30
    (WW) AIGLX: 3D driver claims to not support visual 0x31
    (WW) AIGLX: 3D driver claims to not support visual 0x32
    (WW) AIGLX: 3D driver claims to not support visual 0x33
    (WW) AIGLX: 3D driver claims to not support visual 0x34
    (WW) AIGLX: 3D driver claims to not support visual 0x35
    (WW) AIGLX: 3D driver claims to not support visual 0x36
    (WW) AIGLX: 3D driver claims to not support visual 0x37
    (WW) AIGLX: 3D driver claims to not support visual 0x38
    (WW) AIGLX: 3D driver claims to not support visual 0x39
    (WW) AIGLX: 3D driver claims to not support visual 0x3a
    (WW) AIGLX: 3D driver claims to not support visual 0x3b
    (WW) AIGLX: 3D driver claims to not support visual 0x3c
    (WW) AIGLX: 3D driver claims to not support visual 0x3d
    (WW) AIGLX: 3D driver claims to not support visual 0x3e
    (WW) AIGLX: 3D driver claims to not support visual 0x3f
    (WW) AIGLX: 3D driver claims to not support visual 0x40
    (WW) AIGLX: 3D driver claims to not support visual 0x41
    (WW) AIGLX: 3D driver claims to not support visual 0x42
    (WW) AIGLX: 3D driver claims to not support visual 0x43
    (WW) AIGLX: 3D driver claims to not support visual 0x44
    (WW) AIGLX: 3D driver claims to not support visual 0x45
    (WW) AIGLX: 3D driver claims to not support visual 0x46
    (WW) AIGLX: 3D driver claims to not support visual 0x47
    (WW) AIGLX: 3D driver claims to not support visual 0x48
    (WW) AIGLX: 3D driver claims to not support visual 0x49
    (WW) AIGLX: 3D driver claims to not support visual 0x4a
    (WW) AIGLX: 3D driver claims to not support visual 0x4b
    (WW) AIGLX: 3D driver claims to not support visual 0x4c
    (WW) AIGLX: 3D driver claims to not support visual 0x4d
    (WW) AIGLX: 3D driver claims to not support visual 0x4e
    (WW) AIGLX: 3D driver claims to not support visual 0x4f
    (WW) AIGLX: 3D driver claims to not support visual 0x50
    (WW) AIGLX: 3D driver claims to not support visual 0x51
    (WW) AIGLX: 3D driver claims to not support visual 0x52
    (WW) AIGLX: 3D driver claims to not support visual 0x53
    (WW) AIGLX: 3D driver claims to not support visual 0x54
    (WW) AIGLX: 3D driver claims to not support visual 0x55
    (WW) AIGLX: 3D driver claims to not support visual 0x56
    (WW) AIGLX: 3D driver claims to not support visual 0x57
    (WW) AIGLX: 3D driver claims to not support visual 0x58
    (WW) AIGLX: 3D driver claims to not support visual 0x59
    (WW) AIGLX: 3D driver claims to not support visual 0x5a
    (WW) AIGLX: 3D driver claims to not support visual 0x5b
    (WW) AIGLX: 3D driver claims to not support visual 0x5c
    (WW) AIGLX: 3D driver claims to not support visual 0x5d
    (WW) AIGLX: 3D driver claims to not support visual 0x5e
    (WW) AIGLX: 3D driver claims to not support visual 0x5f
    (WW) AIGLX: 3D driver claims to not support visual 0x60
    (WW) AIGLX: 3D driver claims to not support visual 0x61
    (WW) AIGLX: 3D driver claims to not support visual 0x62
    (WW) AIGLX: 3D driver claims to not support visual 0x63
    (WW) AIGLX: 3D driver claims to not support visual 0x64
    (WW) AIGLX: 3D driver claims to not support visual 0x65
    (WW) AIGLX: 3D driver claims to not support visual 0x66
    (WW) AIGLX: 3D driver claims to not support visual 0x67
    (WW) AIGLX: 3D driver claims to not support visual 0x68
    (WW) AIGLX: 3D driver claims to not support visual 0x69
    (WW) AIGLX: 3D driver claims to not support visual 0x6a
    (WW) AIGLX: 3D driver claims to not support visual 0x6b
    (WW) AIGLX: 3D driver claims to not support visual 0x6c
    (WW) AIGLX: 3D driver claims to not support visual 0x6d
    (WW) AIGLX: 3D driver claims to not support visual 0x6e
    (WW) AIGLX: 3D driver claims to not support visual 0x6f
    (WW) AIGLX: 3D driver claims to not support visual 0x70
    (WW) AIGLX: 3D driver claims to not support visual 0x71
    (WW) AIGLX: 3D driver claims to not support visual 0x72
    (II) AIGLX: Loaded and initialized /usr/lib/dri/fglrx_dri.so
    ----------
    glxinfo
    Code:
    name of display: :0.0
    display: :0  screen: 0
    direct rendering:
    Yes
    ----------
    DRI enabled:
    Code:
    grep DRI /var/log/Xorg.0.log
    (II) Loading extension XFree86-DRI
    (**) fglrx(0): Option "NoDRI" "no"
    (**) fglrx(0): NoDRI = NO
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): [DRI] installation complete
    (II) GLX: Initialized DRI GL provider for screen 0
    -----------
    My xorg.conf
    Code:
    # /.../
    *snip*
    Section "Module"
      Load         "dbe"
      Load         "type1"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
      Load         "dri"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
    EndSection
    
    *snip*
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  331 207
      HorizSync    30-66
      Identifier   "Monitor[0]"
      ModelName    "NC8230"
      Option       "DPMS"
      VendorName   "HITACHI"
      VertRefresh  50-65
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "Radeon Mobility X600 (M24) 3150 (PCIE)"
      BusID        "1:0:0"
      Driver       "fglrx"
      Identifier   "Device[0]"
      #Option       "NoDDC"
      Option       "UseInternalAGPGART" "no"
      Option       "no_accel" "no"
      Option       "no_dri" "no"
      Option       "mtrr" "off"
      Option       "ScreenOverlap" "0"
      Option       "GammaCorrectionI" "0x00000000"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "Capabilities" "0x00000000"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "VideoOverlay" "on"
      Option       "OpenGLOverlay" "off"
      Option       "CenterMode" "off"
      Option       "PseudoColorVisuals" "off"
      Option       "Stereo" "off"
      Option       "StereoSyncEnable" "1"
      Option       "FSAAEnable" "no"
      Option       "FSAAScale" "1"
      Option       "FSAADisableGamma" "no"
      Option       "FSAACustomizeMSPos" "no"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "FSAAMSPosX2" "0.000000"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "UseFastTLS" "0"
      Option       "BlockSignalsOnLock" "on"
      Option       "ForceGenericCPU" "no"
      Option       "KernelModuleParm" "locked-userpages=0"
      VendorName   "ATI"
    EndSection
    
    
    Section "Screen"
      Option         "AddARGBGLXVisuals" "True"
      Option         "DisableGLXRootClipping" "True"
      Option         "RenderAccel" "True"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1680x1050" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1680x1050" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1680x1050" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1680x1050" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      InputDevice  "Mouse[3]" "SendCoreEvents"
      Screen       "Screen[0]"
      Option       "AIGLX" "on"
    EndSection
    
    Section "Extensions"
     Option       "Composite" "on"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    Could anyone help?
    Thanks!

  5. #5
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Quote Originally Posted by zkyez View Post
    i use opensuse and i have the still problem:

    florin@florinsam-laptop:/etc/xdg> compiz
    compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
    compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0

    any ideeas?


    i don`t have /etc/xdg/compiz-manager. any ideeas?
    I changed /usr/bin/compiz-manager; added fglrx to the whitelist and removed all ati related things in the blacklist.

    But to no avail. I still get the same error in openSUSE 10.3 amd64. I think this is related to 64bit :/

  6. #6
    Join Date
    Sep 2007
    Posts
    7

    Default

    i have 32 bit and it`s the same:

    florin@florinsam-laptop:/etc/modprobe.d> compiz --replace
    compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
    compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0

    florinsam-laptop:~ # glxinfo |grep -i direct
    direct rendering: Yes

    florinsam-laptop:~ # glxinfo |grep -i pixmap
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

    running fusion-icon i get:

    florin@florinsam-laptop:/etc/modprobe.d> fusion-icon
    * Detected Session: gnome
    * Searching for installed applications...
    * No GLX_EXT_texture_from_pixmap with direct rendering context
    ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1

  7. #7
    Join Date
    Aug 2007
    Posts
    6,610

    Default

    $LIB looks a bit crazy in that output...

  8. #8
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Alas... back to 40.4 again... XGL didn't even want to run properly with 42 :/

    What is it with openSUSE and ATI?? Amdcccle doesn't want to run properly (also with hack in /etc/profile etc) and now the new drivers runs on Ubuntu but just wont budge on suse :?

  9. #9
    Join Date
    Oct 2007
    Posts
    2

    Default

    Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
    http://dev.compiz-fusion.org/~cybero...-the-hard-way/
    In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).

  10. #10
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Quote Originally Posted by Beno View Post
    Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
    http://dev.compiz-fusion.org/~cybero...-the-hard-way/
    In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).
    openSUSE 10.3 x86_64, followed the instructions, also renamed /usr/lib64/libInd....so.1 --> no succes

    Compiz now segfaults.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •