The location of the php 5.2.x branch has moved to http://museum.php.net/php5/.

If you need to install the pts/build-php-1.3.0, download the package here: http://museum.php.net/php5/php-5.2.9.tar.bz2 and move it to ~/.phoronix-test-suite/installed-tests/pts/build-php-1.3.0/

I just downloaded the suite and found that this was needed in order to run it.