Results 1 to 6 of 6

Thread: 3 Tesla Nvidia Devices and Xorg.conf problems. HELP PLEASEEEE!!!

  1. #1
    Join Date
    Sep 2011
    Posts
    3

    Default 3 Tesla Nvidia Devices and Xorg.conf problems. HELP PLEASEEEE!!!

    Hello,

    This is my first post, Im new in this Forum and working with xorg.conf. I have 3 Nvidia Tesla C1060 devices and Ive been trying to set the xorg.conf file up for 2 months with no luck.


    I know this is not the forum topic but I will explain it shortly to understand better the issue:
    >
    >Im working with CUDA and I think the xorg.conf needs to be set well to work properly with 2D and 3D acceleration. Ive tried plenty of differents >xorg.file but never works telling me (nearly always) devices not found.
    >
    >The Main problem is when Im running a GPU Julia set aplicattion (draw slices of the Julia set - boundary of certain class of functions over comple>x number), Im having this error:
    >
    >Xlib: extension "GLX" missing on display ":0.0".
    >freeglut OpenGL GLX extension not supported by display ':0.0'


    I have tried reinstalling Nvidia drivers, glut, freeglut, but I think is because I cant load GLX module because I cant not configure the Xorg file.
    Of course I have tried the easy way to set it (Xorg - configure, nvidia-xconfig

    Anyway, I have lost lots of evening working with xorg configuration that I must set it at any cost...



    PLEASE HELP!!!Anything would be grateful

    Thanks in advance

    Gsr
    Regards


    --------------------------------------------------------------------------------------------------------------------------------------------------

    I few more extra information about my computer:

    $ lshw -C display

    *-display
    description: 3D controller
    product: GT200 [Tesla C1060]
    vendor: nVidia Corporation
    physical id: 0
    bus info: pci@0000:0a:00.0
    version: a1
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list rom
    configuration: driver=nvidia latency=0
    resources: irq:24 memory:f7000000-f7ffffff memory:f0000000-f3ffffff memory:f8000000-f9ffffff ioport:cc00(size=128) memory:f6f80000-f6ffffff
    *-display UNCLAIMED
    description: VGA compatible controller
    product: ASPEED Graphics Family
    vendor: ASPEED Technology, Inc.
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 10
    width: 32 bits
    clock: 33MHz
    capabilities: pm vga_controller cap_list
    configuration: latency=0
    resources: memory:fb000000-fb7fffff memory:fafe0000-faffffff ioport:8c00(size=128)
    *-display
    description: 3D controller
    product: GT200 [Tesla C1060]
    vendor: nVidia Corporation
    physical id: 0
    bus info: pci@0000:82:00.0
    version: a1
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list rom
    configuration: driver=nvidia latency=0
    resources: irq:48 memory:dd000000-ddffffff memory:d4000000-d7ffffff memory:de000000-dfffffff ioport:ec00(size=128) memory:dcf80000-dcffffff
    *-display
    description: 3D controller
    product: GT200 [Tesla C1060]
    vendor: nVidia Corporation
    physical id: 0
    bus info: pci@0000:81:00.0
    version: a1
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list rom
    configuration: driver=nvidia latency=0
    resources: irq:54 memory:d9000000-d9ffffff memory:d0000000-d3ffffff memory:da000000-dbffffff ioport:dc00(size=128) memory:d8f80000-d8ffffff


    Devices info:

    [deviceQueryDrv] starting...
    CUDA Device Query (Driver API) statically linked version
    There are 3 devices supporting CUDA (idem)

    Device 0, 1, 2: "Tesla C1060"
    CUDA Driver Version: 4.0
    CUDA Capability Major/Minor version number: 1.3
    Total amount of global memory: 4096 MBytes (4294770688 bytes)
    (30) Multiprocessors x ( 8) CUDA Cores/MP: 240 CUDA Cores
    GPU Clock rate: 1.30 GHz
    Memory Clock rate: 800.00 Mhz
    Memory Bus Width: 512-bit
    Max Texture Dimension Sizes 1D=(8192) 2D=(65536,32768) 3D=(2048,2048,2048)
    Max Layered Texture Size (dim) x layers 1D=(8192) x 512, 2D=(8192,8192) x 512
    Total amount of constant memory: 65536 bytes
    Total amount of shared memory per block: 16384 bytes
    Total number of registers available per block: 16384
    Warp size: 32
    Maximum number of threads per block: 512
    Maximum sizes of each dimension of a block: 512 x 512 x 64
    Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
    Texture alignment: 256 bytes
    Maximum memory pitch: 2147483647 bytes
    Concurrent copy and execution: Yes with 1 copy engine(s)
    Run time limit on kernels: No
    Integrated GPU sharing Host Memory: No
    Support host page-locked memory mapping: Yes
    Concurrent kernel execution: No
    Alignment requirement for Surfaces: Yes
    Device has ECC support enabled: No
    Device is using TCC driver mode: No
    Device supports Unified Addressing (UVA): No
    Device PCI Bus ID / PCI location ID: 10 / 0, 130/ 0, 129/ 0
    Compute Mode:
    < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

  2. #2
    Join Date
    Apr 2007
    Location
    Arctic circle, Finland
    Posts
    283

    Default

    hmm Tesla, maybe you colud get better help from here:
    http://forums.nvidia.com/index.php?showforum=68

    What does command nvidia-smi -a say? For command nvidia-xconfig you need system administrator priviledges. So depending system it's done by sudo nvidia-xconfig or by root account.

  3. #3
    Join Date
    Sep 2011
    Posts
    3

    Default

    $ nvidia-smi -a


    ==============NVSMI LOG==============

    Timestamp : Mon Sep 19 18:37:39 2011

    Driver Version : 280.13

    Attached GPUs : 3

    GPU 0000:0A:00.0
    Product Name : Tesla C1060
    Display Mode : Disabled
    Persistence Mode : Disabled
    Driver Model
    Current : N/A
    Pending : N/A
    Serial Number : N/A
    GPU UUID : GPU-c6f02b6525f0e31c-4647c011-459da5a6-8601bd2e-9e7525f9953178be0cd181b1
    Inforom Version
    OEM Object : N/A
    ECC Object : N/A
    Power Management Object : N/A
    PCI
    Bus : A
    Device : 0
    Domain : 0
    Device Id : 05E710DE
    Bus Id : 0000:0A:00.0
    Fan Speed : 35 %
    Memory Usage
    Total : 4095 Mb
    Used : 3 Mb
    Free : 4092 Mb
    Compute Mode : Default
    Utilization
    Gpu : 0 %
    Memory : 0 %
    Ecc Mode
    Current : N/A
    Pending : N/A
    ECC Errors
    Volatile
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Aggregate
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Temperature
    Gpu : 46 C
    Power Readings
    Power State : P8
    Power Management : N/A
    Power Draw : N/A
    Power Limit : N/A
    Clocks
    Graphics : 399 MHz
    SM : 799 MHz
    Memory : 297 MHz
    GPU 0000:82:00.0
    Product Name : Tesla C1060
    Display Mode : Disabled
    Persistence Mode : Disabled
    Driver Model
    Current : N/A
    Pending : N/A
    Serial Number : N/A
    GPU UUID : GPU-e25674973c66f696-8636873c-ed56d45c-bb3325bc-5ce503f5be35f2d0d8879333
    Inforom Version
    OEM Object : N/A
    ECC Object : N/A
    Power Management Object : N/A
    PCI
    Bus : 82
    Device : 0
    Domain : 0
    Device Id : 05E710DE
    Bus Id : 0000:82:00.0
    Fan Speed : 35 %
    Memory Usage
    Total : 4095 Mb
    Used : 3 Mb
    Free : 4092 Mb
    Compute Mode : Default
    Utilization
    Gpu : 0 %
    Memory : 0 %
    Ecc Mode
    Current : N/A
    Pending : N/A
    ECC Errors
    Volatile
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Aggregate
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Temperature
    Gpu : 41 C
    Power Readings
    Power State : P8
    Power Management : N/A
    Power Draw : N/A
    Power Limit : N/A
    Clocks
    Graphics : 399 MHz
    SM : 799 MHz
    Memory : 297 MHz
    GPU 0000:81:00.0
    Product Name : Tesla C1060
    Display Mode : Disabled
    Persistence Mode : Disabled
    Driver Model
    Current : N/A
    Pending : N/A
    Serial Number : N/A
    GPU UUID : GPU-d5921feb40f24adc-d3d119ad-c9bfc290-c4584a22-5dbf93ce148db34efdc7d5d5
    Inforom Version
    OEM Object : N/A
    ECC Object : N/A
    Power Management Object : N/A
    PCI
    Bus : 81
    Device : 0
    Domain : 0
    Device Id : 05E710DE
    Bus Id : 0000:81:00.0
    Fan Speed : 35 %
    Memory Usage
    Total : 4095 Mb
    Used : 3 Mb
    Free : 4092 Mb
    Compute Mode : Default
    Utilization
    Gpu : 0 %
    Memory : 0 %
    Ecc Mode
    Current : N/A
    Pending : N/A
    ECC Errors
    Volatile
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Aggregate
    Single Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Double Bit
    Device Memory : N/A
    Register File : N/A
    L1 Cache : N/A
    L2 Cache : N/A
    Total : N/A
    Temperature
    Gpu : 40 C
    Power Readings
    Power State : P8
    Power Management : N/A
    Power Draw : N/A
    Power Limit : N/A
    Clocks
    Graphics : 399 MHz
    SM : 799 MHz
    Memory : 297 MHz


    I have privilegies, so imposible.

  4. #4
    Join Date
    Apr 2007
    Location
    Arctic circle, Finland
    Posts
    283

    Default

    That nvidia-smi -a command seems not to recognize system correctly(somewhere read that it's a known bug). Hmm maybe you should try older drivers, which have been especially made for cuda:
    http://developer.nvidia.com/cuda-toolkit-40#Linux

    Developer Drivers for Linux should work better. And you should get better support from nvidia forums:
    http://forums.nvidia.com/index.php?showforum=68

  5. #5
    Join Date
    Sep 2011
    Posts
    3

    Default

    Thanks tuke81,

    how do you know it isnŽt recongnizing correctly? where can I read that bug? I have try installing a lower driver version but I get a missmatching with the tolkit version and the kernel version (keeps the newest one). if I do it, IŽll paste it the error.

    IŽve asked on nvidia forums with no luck yet.

    Regards

  6. #6
    Join Date
    Apr 2007
    Location
    Arctic circle, Finland
    Posts
    283

    Default

    Hmm I'm far from expert of nvidia drivers. But what libglx are u using now?
    Code:
    ls -l /usr/lib/xorg/modules/extensions/libglx.so
    You should also check if logs says something conserning glx(logfile: /var/log/Xorg.0.log).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •