Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ATI 8.42.3 + openSuSE10.3 x64 = several problems

  1. #1
    Join Date
    Oct 2007
    Posts
    31

    Default ATI 8.42.3 + openSuSE10.3 x64 = several problems

    Hi all,
    being very new to linux i'll try to explain this the best i can.... so please bear with me

    So, i'm using openSuSE 10.3 x64, with kernel 2.6.22.9-0.4 and Xorg-x11 7.2-135.2. I tried to install the drivers following the instructions opensuse_ATI HOWTO. It has worked for me before while i was using 10.2 and the 8.40 drivers. But not now.


    Now on to the problems:

    1. Sax2 says it can not offer activation of the 3D subsystem because the card/driver does not support 3D, and freezes on exit.

    Driver Instalation goes through fine, no errors, although some warnings were seen. I go on to "sax2 -r -m 0=fglrx" after the aticonfig command, and sax2 starts fine... except for the note mentioning that no 3D activation is available. I go on to configure display size and resolution, test and save. No problem here. When i click exit i get a black screen with a strip that turns white with time, on the lower part of the display. If i type reboot and press enter, without actually seing anything, the computer will reboot.


    2. fgl_glxgears does not run at all.
    HTML Code:
    geneticavs01:/home/kmz # fgl_glxgears
    Using GLX_SGIX_pbuffer
    X Error of failed request:  GLXUnsupportedPrivateRequest
      Major opcode of failed request:  143 (GLX)
      Minor opcode of failed request:  16 (X_GLXVendorPrivate)
      Serial number of failed request:  41
      Current serial number in output stream:  42
    glxinfo and and fglrxinfo provide the correct information, although i'm not sure, from looking at the ati_howto, if the "client glx" part of glxinfo should say ATI and not SGI

    HTML Code:
    geneticavs01:/home/kmz # fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI MOBILITY RADEON X700
    OpenGL version string: 2.0.6958 Release
    HTML Code:
    geneticavs01:/home/kmz # glxinfo
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
        GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
        GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
        GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: SGI
    client glx version string: 1.4
    client glx extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
        GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
        GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
        GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
        GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
    GLX extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI MOBILITY RADEON X700
    OpenGL version string: 2.0.6958 Release
    OpenGL extensions:
        GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
        GL_ARB_fragment_shader, GL_ARB_multisample, GL_ARB_multitexture,
        GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
        GL_ARB_shader_objects, GL_ARB_shading_language_100, GL_ARB_shadow,
        GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
        GL_ARB_texture_compression, GL_ARB_texture_cube_map,
        GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
        GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
        GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
        GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
        GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
        GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap,
        GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil,
        GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
        GL_ATI_texture_float, GL_EXT_bgra, GL_EXT_blend_color,
        GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
        GL_EXT_compiled_vertex_array, GL_EXT_copy_texture,
        GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
        GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,
        GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
        GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
        GL_EXT_secondary_color, GL_EXT_separate_specular_color,
        GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
        GL_EXT_texgen_reflection, GL_EXT_texture3D,
        GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
        GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
        GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
        GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
        GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
        GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_vertex_array,
        GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_texgen_reflection,
        GL_SGIS_generate_mipmap, GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod,
        GL_WIN_swap_hint, WGL_EXT_swap_control
    glu version: 1.3
    glu extensions:
        GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    3. Desktop graphical corruption.
    I have 2 small rectangles at the lower right area of the desktop.. with weird colours. If i scroll some page on firefox or some pdf it changes slightly.


    And these are the problems i can see so far.
    I went through the troubleshooting section of the opensuse_ati_howto with no success.

    ...so i hope some of you can give me some hints
    thanks,
    Carlos

  2. #2
    Join Date
    Oct 2007
    Posts
    2

    Default

    Just got my 3d working here on opensuse 10.3 with a 9600 pro.

    I was experiencing the same pop up warning about 3d acceleration not being supported by my card, I got it working by doing an

    aticonfig --initial --force

    Now I have to get aiglx and compiz working...

    Good luck

    Tpyo

  3. #3
    Join Date
    Oct 2007
    Posts
    31

    Default

    Can you tell me some details about your setup?

    is it x64?
    Do you use the same versions of the kernel and xorg as i do?
    fgl_glxgears runs ok?


    thanks,
    Carlos

  4. #4
    Join Date
    Oct 2007
    Posts
    2

    Default

    Running default 32 bit kernel.

    After testing out quite a few opengl programs, about half those I ran though cause the system to hard lock forcing me to reset the computer..

    Maybe I shouldnt be trying to help people make their system work "like mine" quite yet :P Going to try to upgrade to Xorg 7.3, reinstall the driver and try again.


    Tpyo
    Last edited by typoboy; 10-25-2007 at 10:10 AM.

  5. #5
    Join Date
    Oct 2007
    Posts
    2

    Default

    I have opensuse 10.3 x86_64 and I get exactly the same beavior.
    And with 8.41 it was similar but more frequently.

    Neither with 8.40, 8.41, nor 8.42 I can run amdcccld and aticonfig hangs up and don't return.

  6. #6
    Join Date
    Oct 2007
    Posts
    42

    Default

    Hmm i guess i`m not only one who have problem with opensuse 10.3+ 8.41.7/8.42.3, i get installed the driver, aticonfig get well, and sax2 -r -m 0=fglrx or, sax2 -r, worked also, but after reboot just black screen, and have to use (init 3) to get log in.
    In 10.2 and 8.41.7 worked guide well, hmm wonder is if the problem is in driver or opensuse, or both..

    Ps. sorry about my bad english.

  7. #7
    Join Date
    Oct 2007
    Posts
    2

    Default

    About running 'amdcccle' (Catalyst Control Center)? Did you had problems with it?


    When I run amdcccle I get:
    # amdcccle
    amdcccle: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock’ failed.
    Aborted

    I read somewhere to do “export LIBXCB_ALLOW_SLOPPY_LOCK=1″ before call the program.
    I did it and the error did not appeared but the control center still did not starts.
    Last edited by jerenmye; 10-25-2007 at 02:25 PM.

  8. #8
    Join Date
    Oct 2007
    Posts
    3

    Default

    Exact same thing for the SUSE 10.3 32bit

    localhost:/home/centurion # fgl_glxgears
    Using GLX_SGIX_pbuffer
    X Error of failed request: GLXUnsupportedPrivateRequest
    Major opcode of failed request: 143 (GLX)
    Minor opcode of failed request: 16 (X_GLXVendorPrivate)
    Serial number of failed request: 42
    Current serial number in output stream: 43

    ocalhost:/home/centurion # glxgears
    24647 frames in 5.0 seconds = 4929.399 FPS
    24893 frames in 5.0 seconds = 4978.560 FPS
    24822 frames in 5.0 seconds = 4964.302 FPS
    25083 frames in 5.0 seconds = 5016.504 FPS
    25053 frames in 5.0 seconds = 5010.501 FPS
    XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
    after 131157 requests (131156 known processed) with 0 events remaining.
    Last edited by Centurion; 10-25-2007 at 04:20 PM.

  9. #9
    Join Date
    Oct 2007
    Posts
    3

    Default

    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1600 Series
    OpenGL version string: 2.0.6958 Release


    and the sloppy_joe lock fix's the error but not the problem amdcccle just wont start

  10. #10
    Join Date
    Oct 2007
    Posts
    13

    Default

    Quote Originally Posted by jerenmye View Post
    About running 'amdcccle' (Catalyst Control Center)? Did you had problems with it?


    When I run amdcccle I get:
    # amdcccle
    amdcccle: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock’ failed.
    Aborted

    I read somewhere to do “export LIBXCB_ALLOW_SLOPPY_LOCK=1″ before call the program.
    I did it and the error did not appeared but the control center still did not starts.
    i get the same error when i run amdcccle. i am on 64 bit, but i have no corruption on my x1400 mobile. but, i cant get aiglx to work with compiz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •