Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Ati Driver 8.42 + Mandriva 2008 = Unsolved problems

  1. #11
    Join Date
    Oct 2007
    Posts
    5

    Default

    There is solution on the forums.mandriva.com too:
    http://forum.mandriva.com/viewtopic....dbad3f1#388540

  2. #12
    Join Date
    Oct 2007
    Posts
    5

    Default

    There is solution on forums.mandriva.com too:
    http://forum.mandriva.com/viewtopic....dbad3f1#388540

  3. #13
    Join Date
    Aug 2007
    Posts
    7

    Default

    Quote Originally Posted by Jorge View Post
    Maybe this could help:
    No, the problem is not even getting to the install. It is failing in the RPM creation when it builds the Mandriva package. It actually says there are TOO many libGL.so's. At this point it can't create a RPM package to install.

    Thanks for they idea though.

    Chris

  4. #14
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    27

    Unhappy +1 here

    Double post, sorry.
    Last edited by Zibi1981; 10-26-2007 at 05:56 PM.

  5. #15
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    27

    Unhappy +1 here

    I have the same problem on my Mandriva 2008.0

    Code:
    [zibi1981@localhost ATI]$ sh ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Mandriva/2008
    Created directory fglrx-install.Lv8465
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.42.3
    .....................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    ..................................................
    .......................................
    ==================================================
     ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Mandriva/2008
    Package build failed!
    Package build utility output:
    error: file /home/zibi1981/tmp/ati.KR8550/SOURCES/ati-driver-installer-8.42.3-x86.x86_64.run missing: No such file or directory
    Removing temporary directory: fglrx-install.Lv8465
    Installation using the script didn't work for me either. Anyone found a solution?

  6. #16
    Join Date
    Jun 2007
    Posts
    260

    Default

    Anssi and I are co-ordinating the release of the new driver for Cooker and 2008 at the moment. It will hit Cooker first to make sure it works then be backported to 2008.
    That was from Adam Williamson.

    I also tried various methods to install 8.42 on 2008, but with no luck.
    I am waiting for the backports Adam mentioned, unless somebody figures out how to install the drivers manually sooner :P

  7. #17
    Join Date
    Oct 2007
    Posts
    7

    Default

    We got to wait as usual as Mandriva's Users

  8. #18
    Join Date
    Jun 2007
    Posts
    260

    Default

    Quote Originally Posted by Yayoooli View Post
    We got to wait as usual as Mandriva's Users
    Personally, I wouldn't mind that.

    When they're the ones packaging it, I get few problems if any, and also I know that if I upgrade my kernel, dkms will take care of the module building.

  9. #19
    Join Date
    Oct 2007
    Posts
    5

    Default

    Quote Originally Posted by Zibi1981 View Post
    I have the same problem on my Mandriva 2008.0
    The packaging scripts for several distributions (including Mandriva 2008, 2007.1 seems OK) are broken. I installed via GUI installator (and select not to make distribution specific packages) - everithing was OK and driver works excellently for me .
    Could you post output of GUI installer? it is logging into /usr/share/ati/fglrx-install.log.

    Jirka

  10. #20
    Join Date
    Oct 2007
    Location
    Barcelona
    Posts
    15

    Default

    Quote Originally Posted by DarkFoss View Post
    I've seen one of the dkms rpm's removed when uninstalling the Mandriva ATI drivers.

    Usually the dkms-2.0.17-13mdv2008.0 
    DarkFoss, did you manage to get compiz working?

    I extracted the files from the installer (./ati...run --extract (directory)), then I tinkered with some scripts and the ati.spec, and managed to build the packages.

    Once installed, it seems that the driver load OK, then I've tinkered with xorg to enable AIGLX and so, but I can't get neither Compiz nor xgl working.

    Instead, I have an error already reported here, but referred to SUSE. The solution suggested is not applicable to Mandriva, because SUSE uses different files.

    As a clue for other people, when rpmbuild is executed, show errors about duplicated files. This is due to (in %files in the spec file):
    -One line refers to a directory
    -Then other line refers to a file deeper in the same directory indicated in other previous line.
    Then rpmbuild says that a file is found more than once.

    Regards
    Osado

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •