Results 1 to 3 of 3

Thread: Problems on fresh install of Kubuntu Gutsy

  1. #1
    Join Date
    Oct 2007
    Posts
    12

    Default Problems on fresh install of Kubuntu Gutsy

    Now I installed Kubuntu Gutsy last weekend, but made sure not to install the restricted drivers or an old fglrx version driver since I knew this new version was coming out in a few days. So today I follow this guide: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    The only thing there that I did not do is this:
    DISABLED_MODULES="fglrx"

    Upon restarting the computer, I get this for fglrxinfo
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
    I have looked at a few threads and tried making changes to the xorg.conf file, but nothing has worked. Here is my current version:

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    
    # Uncomment if you have a wacom tablet
    #       InputDevice     "stylus"        "SendCoreEvents"
    #       InputDevice     "cursor"        "SendCoreEvents"
    #       InputDevice     "eraser"        "SendCoreEvents"
            Identifier     "Default Layout"
            Screen      0  "aticonfig-Screen[0]" 0 0
            InputDevice    "Generic Keyboard"
            InputDevice    "Configured Mouse"
            InputDevice    "Synaptics Touchpad"
            Option      "AIGLX" "true"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
            Load  "i2c"
            Load  "bitmap"
            Load  "ddc"
            Load  "dri"
            Load  "extmod"
            Load  "freetype"
            Load  "glx"
            Load  "int10"
            Load  "vbe"
    EndSection
    
    Section "InputDevice"
            Identifier  "Generic Keyboard"
            Driver      "kbd"
            Option      "CoreKeyboard"
            Option      "XkbRules" "xorg"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
            Identifier  "Configured Mouse"
            Driver      "mouse"
            Option      "CorePointer"
            Option      "Device" "/dev/input/mice"
            Option      "Protocol" "ImPS/2"
            Option      "ZAxisMapping" "4 5"
            Option      "Emulate3Buttons" "true"
    EndSection
    
    Section "InputDevice"
            Identifier  "Synaptics Touchpad"
            Driver      "synaptics"
            Option      "SendCoreEvents" "true"
            Option      "Device" "/dev/psaux"
            Option      "Protocol" "auto-dev"
            Option      "HorizEdgeScroll" "0"
    EndSection
    
    Section "InputDevice"
            Identifier  "stylus"
            Driver      "wacom"
            Option      "Device" "/dev/input/wacom"
            Option      "Type" "stylus"
            Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
            Identifier  "eraser"
            Driver      "wacom"
            Option      "Device" "/dev/input/wacom"
            Option      "Type" "eraser"
            Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
            Identifier  "cursor"
            Driver      "wacom"
            Option      "Device" "/dev/input/wacom"
            Option      "Type" "cursor"
            Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]"
            Driver      "fglrx"
            Option      "VideoOverlay" "on"
            Option      "OpenGLOverlay" "off"
            BusID       "PCI:1:5:0"
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]"
            Device     "aticonfig-Device[0]"
            Monitor    "aticonfig-Monitor[0]"
            DefaultDepth     24
            SubSection "Display"
                    Modes           "1280x800"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "DRI"
            Mode         0666
    EndSection
    
    Section "Extensions"
            Option      "Composite" "Enable"
    EndSection

    Please help. Thanks in advance.

  2. #2
    Join Date
    Oct 2007
    Posts
    12

    Default

    Ok, I may have found something. I looked in the /var/log/Xorg.0.log and found something about DRI initialization failed because it was trying to load the 8.37 driver.

    So, I blacklisted the restricted-driver and now I am getting this:

    Code:
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.0.0
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0x40000000 FBMappedSize: 0x08000000
    (==) fglrx(0): Write-combining range (0xc0000000,0x8000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1280,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,800) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1280 x 7391
    (==) fglrx(0): Backing store disabled

  3. #3
    Join Date
    Oct 2007
    Posts
    12

    Default

    This seems to have fixed it for me.

    http://ubuntuforums.org/showpost.php...9&postcount=34

    But now it takes like 5 times longer to boot up my computer, and after running glxgears I have some screen corruption on the bottom right, as seen in some of the other pics on this board.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •