Results 1 to 2 of 2

Thread: 8.42.3 glxinfo segfaults

  1. #1
    Join Date
    Oct 2007
    Posts
    1

    Default 8.42.3 glxinfo segfaults

    When I try to run any gl app I get a segmentation fault since updating to 8.42.3

    My system is:
    Gentoo amd64
    kernel 2.6.22-gentoo
    xorg 7.3
    Turion X2
    ATI x200m

    this is the same problem I was getting with 8.41 before I downgraded. Any ideas on how to fix it?

  2. #2
    Join Date
    Oct 2007
    Posts
    2

    Default ATI installer's package generation or packages are broken.

    I was having this same problem with my installation.

    I have a openSUSE 10.3, glxinfo, glxgears, fglrxinfo and fgl_glxgears all seg faulted (mainly, any program that tried using OpenGL was segfaulting on me).

    My problem was solved when I didn't use the built-in functionality of the installer that generates a package for the distribution, and used the installer directly.

    Here's my steps (don't know how these can apply to Gentoo):

    1 - Prepare kernel (taken from here):

    Code:
    # cd /usr/src/linux-<version>
    # make mrproper
    # make cloneconfig
    # make modules_prepare
    and one last command to clean the kernel source:

    Code:
    # make clean
    2 - Remove any previous installations:

    Code:
    # rpm -e $(rpm -qa | grep fglrx)
    3 - Remove any left over:

    Code:
    # rm -fR `find /lib /lib64 /usr -name *fglrx*`
    4 - Run the visual setup for the ATI driver:

    Code:
    # sh <LOCATION_OF_ATI_DOWNLOAD>/ati-driver-installer-8.42.3-x86.x86_64.run
    Follow the steps and then reboot.

    I hope it helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •