Page 7 of 7 FirstFirst ... 567
Results 61 to 68 of 68

Thread: AMD A6-3400M not working on Linux kernel 3.0

  1. #61
    Join Date
    Jul 2011
    Posts
    75

    Default

    Quote Originally Posted by satan0rx View Post
    Sorry for hijacking this thread

    I'm like planning buying a new notebook, with sufficient GPU power to play nexuiz / xonotic.

    On my current 965gm this is a pain in the ass (~20fps), although i'm satisfied with the intel offering otherwise.

    now I'm planning a a6 3410mx (or the new gen intel core i5-2xxx processor)

    So I have a question on the guys with a llano notebook:

    a) is the nexuiz / xonotic performance good?
    for me open source drivers is nice, but not a must, so:
    b) are the OS drivers delivering sufficient performance?
    c) are there issues with the closed source drivers?

    Thanks in advance
    AMD A6-3410MX graphics will have better performance than than the Intel graphics you'll find on the Core i5.

    a) Nexuiz works pretty well, but might be a bit slow on higher settings (I only ever tested Nexuiz on the APU graphics with Catalyst 11.4. Afterwards used only the dedicated card and it was pretty fast there).

    b) For my hardware, the open source drivers work pretty well. 2D was quite fast before but seems to be little slow in the latest git versions. You should use as recent a Linux kernel as possible (preferably Linux 3.2 although 3.1 might be OK). Also, suspend isn't working properly on my laptop right now (i.e no display on resuming). 3D games run pretty slow on the integrated graphics card as expected.

    c) Well, 2D sucks but 3D rocks. Also, the newer proprietary drivers don't work with Gnome 3. In my laptop, same problem with suspending as with open source drivers. Catalyst 11.8 seems to be the best thing to run IMO.

  2. #62
    Join Date
    Dec 2007
    Location
    Munich, Germany
    Posts
    43

    Default

    Ok, thx 4 the info.

    I postponed the idea of buying a new laptop soon, because I have lot's of work to do. So not being able to play
    Nexuiz doesn't hurt right now.

    I also switched to gnome 3 (on my laptop right now), so the info that it doesn't work with Catalyst is important to me.
    And then the suspend bug ... that's hard, because I use suspend quite often.

    So, no AMD for now.

    But again thx for the info!

  3. #63
    Join Date
    May 2011
    Posts
    353

    Default

    Intel GM965 (GMA X3100) is a bit old. Any CPU with Intel HD Graphics will perform a lot better than 20fps. The graphics clock is over twice as fast at Sandy Bridge and for HD 3000 graphics, as well as the older Arrandale, there are also more execution units (12). The memory bandwith is impressive as well. And for Sandy Bridge there'll be support for OpenGL3 in future, your GM965 is stuck at OpenGL 2.1.

  4. #64
    Join Date
    Dec 2007
    Location
    Munich, Germany
    Posts
    43

    Default

    yes, but the problems I see is:
    * The differing mobile CPUs seem to be quite downstripped, with lower number of execution cores, lower frequency, and so on.
    * I'll get a higher screen resolution for my new notebook (main reason to get one )
    * Memory bandwidth isn't much higher. Currently it's 800 MBit/s 128 bit DDR2, the new notebooks will have 1066 MBit/s 128 bit DDR3.

    But I think I'll get an Ivy-Bridge in half a year or so.

  5. #65
    Join Date
    Jul 2011
    Posts
    75

    Default

    Quote Originally Posted by satan0rx View Post
    Ok, thx 4 the info.

    I postponed the idea of buying a new laptop soon, because I have lot's of work to do. So not being able to play
    Nexuiz doesn't hurt right now.

    I also switched to gnome 3 (on my laptop right now), so the info that it doesn't work with Catalyst is important to me.
    And then the suspend bug ... that's hard, because I use suspend quite often.

    So, no AMD for now.

    But again thx for the info!
    Doesn't mean you have to stay away from AMD. The suspend problem might be specific for my laptop or for a few brands. Also, Catalyst 11.8 works with Gnome 3 (atleast on Fedora 15). Infact, 11.8 is the best version to run right now because 2D works amazingly well, works with Gnome 3 and suspend/resume works as well. The only reason I use 11.11 and higher is because the XBMC with XVBA ppa for Ubuntu requires Catalyst 11.11 and above, so I'll revert back to 11.8 once I figure out how to compile XBMC properly.

  6. #66
    Join Date
    Jun 2010
    Posts
    49

    Default

    Running Chakra Linux Archimedes, during install Catalyst doesnt install. However after upgrade Catalyst installs fine, have to add nomodeset to kernel, fglrx to rc.conf and everything works fine with full resolution on my ASUS X53T laptop. The dual graphic ATI 6720G2 work at full resolution. Battery life is surprisingly good as well.

  7. #67
    Join Date
    Jul 2011
    Posts
    75

    Default

    Quote Originally Posted by linuxforall View Post
    Running Chakra Linux Archimedes, during install Catalyst doesnt install. However after upgrade Catalyst installs fine, have to add nomodeset to kernel, fglrx to rc.conf and everything works fine with full resolution on my ASUS X53T laptop. The dual graphic ATI 6720G2 work at full resolution. Battery life is surprisingly good as well.
    This is the open source AMD forum. Since I posted here, it should be obvious that I'm talking about the open source driver. The title for the thread does need to be changed though. It should be more like "Radeon HD6520G on my laptop isn't working with KMS on Linux kernel 3.0"

  8. #68
    Join Date
    Jun 2010
    Posts
    49

    Default

    Quote Originally Posted by sandy8925 View Post
    This is the open source AMD forum. Since I posted here, it should be obvious that I'm talking about the open source driver. The title for the thread does need to be changed though. It should be more like "Radeon HD6520G on my laptop isn't working with KMS on Linux kernel 3.0"

    In that case, the open source driver in Chakra works fine but doesn't support full resolution, the one included in Ubuntu 12.04LTS beta 1 does work fine at full resolution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •