Results 1 to 3 of 3

Thread: Cannot build F7-x86_64 rpms...

  1. #1
    Join Date
    Oct 2007
    Posts
    43

    Default Cannot build F7-x86_64 rpms...

    So, I just noticed that the 8.42.3 drivers were released on the ATI website for my Radeon Xpress 200M chipset (I thought it was only for newer cards). Anyway, I tried building the packages for Fedora 7 64-bit, and get the following errors:

    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/F7
    mv: cannot stat `/tmp/ATI-fglrx-8.42.3-1-22118-root/BUILD/ATI-fglrx-8.42.3/usr/X11R6/lib/modules/dri/*': No such file or directory
    mv: cannot stat `/tmp/ATI-fglrx-8.42.3-1-22118-root/BUILD/ATI-fglrx-8.42.3/usr/X11R6/lib/*.so.*': No such file or directory
    Package build failed!


    It should be no surprise that the requested files/directories don't exist...this is 64-bit, so the script should be looking in:
    /tmp/ATI-fglrx-8.42.3-1-22118-root/BUILD/ATI-fglrx-8.42.3/usr/X11R6/lib64/*

    I tried extracting the installer files, and poking around in there to see what I could fix, but I'm at a loss. Any suggestions?

  2. #2
    Join Date
    Jul 2007
    Location
    Seoul, Korea
    Posts
    22

  3. #3
    Join Date
    Oct 2007
    Posts
    43

    Default

    Right...I had figured out that much on my own. What I was trying to do was execute the ati-packager.sh script succesfully. Through some tinkering, I found the following to work, if executed from the root folder extracted from the installer:

    packages/Fedora/ati-packager.sh --buildpkg F7

    The readme didn't really make this clear, but it seems to work. At least I can run Google Earth reasonably well now, but other stuff like Beryl/Compiz still don't work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •