Until yesterday I was using a slightly older version of the fglrx drivers (8.3) in a dual head configuration on kubuntu. The only (fairly major really) issue, was that both screens were locked at a resolution of 1024x768. I believe it was some sort of issue with fglrx and EDID - anyway, the upgrade was out to go to Hardy Heron, so I decided to bite the bullet and make the changes. Overall it seems to be working fairly well, and I was finally able to get out of the locked in resolution - at least mostly.

The situation now is that I have one screen at 1280x1024 - the max I believe for the LG 1920P that I have here. The second monitor, also the 1920P however appears to be stuck at a lower resolution, despite having an identical configuration.

Anyone else come across this? Is it a known issue that I've missed looking at? Any ideas or work arounds?
I'm running on an X1300 card and the configuration looks like this:
Code:
Section "ServerLayout"
    Identifier  "Default Layout"                                                                                                                                                       Screen 0 "aticonfig-Screen[0]" 0 0
    Inputdevice "Generic Keyboard"
    Inputdevice "Configured Mouse"
    Option      "AIGLX" "true"                                                                                                                                                     EndSection

Section "Files"
EndSection                                                                                                                                                                         
Section "Module"
    Load        "glx"
    Load        "dbe"                                                                                                                                                                  Load        "v4l"
EndSection

Section "InputDevice"                                                                                                                                                                  Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option      "CoreKeyboard"
    Option      "XkbRules"  "xorg"                                                                                                                                                     Option      "XkbModel"  "pc105"
    Option      "XkbLayout" "us"
EndSection
                                                                                                                                                                                   Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option      "CorePointer"                                                                                                                                                          Option      "Device"    "/dev/input/mice"
    Option      "Protocol"  "ImPS/2"
    Option      "ZAxisMapping"  "4 5"
    Option      "Emulate3Buttons"   "true"                                                                                                                                         EndSection

Section "InputDevice"                                                                                                                                                                  Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option      "CoreKeyboard"
    Option      "XkbRules"  "xorg"                                                                                                                                                     Option      "XkbModel"  "pc105"
    Option      "XkbLayout" "us"
EndSection
                                                                                                                                                                                   Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option      "CorePointer"                                                                                                                                                          Option      "Device"    "/dev/input/mice"
    Option      "Protocol"  "ImPS/2"
    Option      "ZAxisMapping"  "4 5"
    Option      "Emulate3Buttons"   "true"                                                                                                                                         EndSection

Section "Monitor"
    Identifier  "aticonfig-Monitor[0]"                                                                                                                                                 Vendorname  "LG Electronics Inc."
    Modelname   "LG L1920P (Digital)"
    Horizsync   30.0-71.0
    Vertrefresh 56.0-75.0                                                                                                                                                            modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync                                                                                                         modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    Gamma   1.0
EndSection

Section "Monitor"
    Identifier  "aticonfig-Monitor[1]"
    Vendorname  "LG Electronics Inc."
    Modelname   "LG L1920P (Digital)"
    Horizsync   30.0-71.0
    Vertrefresh 56.0-75.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    Gamma   1.0
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]"
    Boardname   "ati"
    Busid       "PCI:1:0:0"
    Driver      "fglrx"
    Screen  0
EndSection

Section "Device"
    Identifier  "aticonfig-Device[1]"
    Boardname   "ati"
    Busid       "PCI:1:0:1"
    Driver      "fglrx"
    Screen  0
EndSection

Section "Screen"
    Identifier  "aticonfig-Screen[0]"
    Device      "aticonfig-Device[0]"
    Monitor     "aticonfig-Monitor[0]"
    Defaultdepth    24
    SubSection "Display"
        Depth   24
        Virtual 1400    1050
        Modes       "1400x1050@60"  "1280x1024@60"  "1280x960@60"   "1152x864@75"   "1024x768@60"   "1024x768@70"   "1024x768@75"   "832x624@75"    "800x600@60"    "800x600@75"
 "800x600@72"    "800x600@56"    "640x480@75"    "640x480@72"    "640x480@60"
    EndSubSection
EndSection

Section "Screen"
    Identifier  "aticonfig-Screen[1]"
    Device      "aticonfig-Device[1]"
    Monitor     "aticonfig-Monitor[1]"
    Defaultdepth    24
    SubSection "Display"
        Depth   24
        Modes       "1400x1050@60"  "1280x1024@60"  "1280x960@60"   "1152x864@75"   "1024x768@60"   "1024x768@70"   "1024x768@75"   "832x624@75"    "800x600@60"    "800x600@75"    "800x600@72"    "800x600@56"    "640x480@75"    "640x480@72"    "640x480@60"
    EndSubSection
EndSection

Section "DRI"
    Group   0
    Mode    0666
EndSection

Section "Extensions"
    Option      "Composite" "Enable"
EndSection

Section "ServerFlags"
EndSection
Any help would be greatly appreciated as virtually everything else is working great now.

Thanks.