Results 1 to 10 of 37

Thread: [8.42.3] X1950Pro AGP vs 9500Pro AGP the winner? Clearly the 9500Pro! ... what?!

Threaded View

  1. #1
    Join Date
    Jan 2007
    Posts
    418

    Default [8.42.3] X1950Pro AGP vs 9500Pro AGP the winner? Clearly the 9500Pro! ... what?!

    Hi all,

    some might remember me complaining about the lack of X1950Pro AGP (realto) support on the 8.41 driver series, making it segfault etc, which was ok, it wasn't a supported card. The 'crappy' thing was that the only driver that DID work was the 8.34.4 one, and only with a secret special trick at that.

    I was getting corruptions on 2d surfaces (ff etc) and 3d didn't work or work highly corrupted (this actually even on 8.42 in ut2004). Setting my AGP-Gart from 128mb to 256 fixed that for the 8.34, and changing it to 512mb fixed it on the 8.42 driver. (the card is a 512mb model, i temp had a 256 model where coincidently i could go to/from 64mb -> 128 -> 256)

    Back to now, I tried using the 8.42.3 driver and got horrible performance, I mentioned it in the big 'the baby is born' thread but that got quickly lost, with 1 comment wether I was having AIGLX/composite issues (i have both disabled). I can play et (not qw) at 20 - 90FPS but it's never smooth. It feels choppy, looks choppy and i got some minor texture corruption on the minimap and map.

    So instead of mindlessly complaining, I put back my old old 9500Pro AGP thatI borrowed my brother (his own was being RMAed) and I tried that one out with 8.42.3

    I now get what all the fuss is about. I get smooth 90FPS without a hiss in ET, it looks smooth, it feels smooth.

    In WoW (wine -opengl) i got marginal performance on the X1950Pro, 5 - 10FPS where 'normal' for busy areas and i've seen anything from 3 fps to 60fps depending on the area. (small narrow buildings/hallways got me up, busy large area's where .. grinding to halt almost) but avg. would be i say anything between 10 - 25fps.

    With the 9500 i'm gettin 25 - 100fps, with 100 more then the 25. Yeah, weird huh

    I'll attach 3 xorg logs, 8.34 and 8.42 - 1950 and the 8.42 for the 9500 Pro

    It seems to me, there's an issue somewhere with the AGP thing still. Since it's the same system/settings, and only video card swapped, I can either be hardware, or driver related, not kernel etc, and the hardware works. (the card is fine in, *sigh* windos)

    Thanks for your reads

    Since phoronix won't let me post my 3 uber big logs, i hosted them myself:
    http://oliver.schinagl.nl/~oliver/xorg.logs

    I 'snipped' the important part from the X1950Pro on the 8.42.3 for those who don't like to read big logs

    Code:
    (II) fglrx(0): [drm] DRM interface version 1.0
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
    (II) fglrx(0): [drm] mapped SAREA 0x2000 to 0xb7edf000
    (II) fglrx(0): [drm] framebuffer handle = 0x3000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.42.3
    (II) fglrx(0):     Date: Oct 19 2007
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.22-gentoo-r8
    (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
    (II) fglrx(0):     Build-Kernel __SMP__:            yes
    (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
    (II) fglrx(0): [drm] register handle = 0x00004000
    (EE) fglrx(0): Failed to enable interrupts.
    (II) fglrx(0): [pci] find AGP GART
    (II) fglrx(0): [agp] Mode=0x1f000a1b bridge: 0x1106/0x0282
    (II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
    (II) fglrx(0): [agp] AGP v3 disable mask   0x00000000
    (II) fglrx(0): [agp] enabling AGP with mode=0x1f000b1a
    (II) fglrx(0): [agp] Remapping MC AGP space (new MCAGPBase = 0xc0000000)
    (II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f000312)
    (II) fglrx(0): [agp] graphics chipset has AGP v3.0 (native mode)
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): FBADPhys: 0xe0100000 FBMappedSize: 0x01000400
    (II) fglrx(0): FBMM initialized for area (0,0)-(1280,3277)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1280 x 2253
    Last edited by oliver; 10-28-2007 at 11:02 AM. Reason: It i the fault of (EE) fglrx(0): Failed to enable interrupts. !!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •