Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Any World of Warcraft / Wine successes with 8.42.3?

  1. #1
    Join Date
    Jul 2007
    Posts
    442

    Default Any World of Warcraft / Wine successes with 8.42.3?

    Previous versions of fglrx ran World of Warcraft's login screens fine, but then crashed when I tried to enter the Realm. However, 8.42.3 just gives me a blank black window and nothing else (apart from music...).

    Does anyone have any Warcraft success stories to share, please?

  2. #2
    Join Date
    Sep 2007
    Posts
    28

    Default

    I play WoW with Cedega and run fine except FPS

  3. #3
    Join Date
    Jul 2007
    Posts
    442

    Default How is your Xorg configured, please?

    Quote Originally Posted by chabo View Post
    I play WoW with Cedega and run fine except FPS
    Can you post your ATI hardware model and xorg.conf, please? Also, are you using the SLUB or SLAB memory allocator in your kernel?

    Also, have you tried playing using just Wine instead of Cedega?

    Thanks,
    Chris

  4. #4
    Join Date
    Sep 2007
    Posts
    28

    Default

    ATI 1950XTX, x86_64 2.6.22-gentoo-r8, SLUB, Cedega 6.0.2
    I've tried Cedega only. I have to check Frame Buffer Objects option in Cedega(without, it has much more FPS, but it flicks).

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "DesktopSetup" "horizontal"
    Option "XAANoOffscreenPixmaps" "true"
    Option "TexturedVideo" "on"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "MaxGARTSize" "256"
    Option "UseFastTLS" "1"
    Option "UseInternalAGPGART" "no"
    EndSection

  5. #5
    Join Date
    Jun 2007
    Posts
    406

    Default

    Option "UseFastTLS" "1"
    try setting this to 0. it should run a little faster with fglrx.

  6. #6
    Join Date
    Oct 2007
    Posts
    2

    Default How I fixed the same problem

    SWEET! I got it working. I purged wine from my harddrive then reinstalled it after I had installed the new drivers. Then I made the following changes in my xorg.conf

    Under "SeverLayout"
    Option "AIGLX" "False"

    And Under "Extensions"
    Option "Composite" "Disable"

    And it worked. Tell me if you have any luck.

  7. #7
    Join Date
    Oct 2007
    Posts
    2

    Default MUST disable vertex shaders

    Oh I realize that having AIGLX and Composite may not make a difference at all I just did it at the same time that I disabled vertex shaders in wow. When vertex shaders are enabled it doesn't work right.

    Once I reinstalled wine It was like half the game would render and I could log in and only see certain graphics like the menu. If was from there that I disabled vertex shaders logged out and it started working. You may need to fine the code that disables vertex shaders in the config.wtf file as I don't know what it is.

  8. #8
    Join Date
    Oct 2007
    Posts
    51

    Default

    Quote Originally Posted by chrisr View Post
    Previous versions of fglrx ran World of Warcraft's login screens fine, but then crashed when I tried to enter the Realm. However, 8.42.3 just gives me a blank black window and nothing else (apart from music...).

    Does anyone have any Warcraft success stories to share, please?
    You need to edit the wine register

    Registry Tweak for FPS Boost

    Open a terminal window, (konsole/terminal/x terminal etc..), type regedit and press enter. This will start the Wine equivalent of the windows registry editor. If you are familiar with using the registry editor under windows then this is pretty much the same.

    1. Find HKEY_CURRENT_USER\Software\Wine\
    2. Highlight the wine folder in the left hand pane by left clicking on it. The icon should change to an open folder.
    3. Click right on the wine folder and select [NEW] then [KEY].
    4. Replace the text "New Key #1" with OpenGL (CaSe Sensitive).
    5. Right click in the right hand pane and select [NEW] then [String Value].
    6. Replace "New Value #1" with "DisabledExtensions" (CaSe sensitive).
    7. Then double click anywhere on the line, a dialog box will open.
    8. In the value field type "GL_ARB_vertex_buffer_object" (without the quotes).

    Note: If you are unable to rename the newly created key "New Key #1" to "OpenGL" then expand the left hand pane of the regedit window using the vertical divider bar. You should now be able to change it. A known bug in Wine is causing this unwanted behavior.

    You should see a significant performance gain.


    This was taken from http://www.wowwiki.com/Linux/Wine

    I had to add a second option to number 8 in order to get my hd2600 working.

    GL_ARB_vertex_buffer_object;GL_ARB_vertex_program

    And heres an image showing it

    http://img484.imageshack.us/my.php?i...ryeditonf0.png

  9. #9
    Join Date
    Oct 2007
    Location
    New York
    Posts
    17

    Default

    Have you tried working with WoW in a window or in a emulated desktop?

  10. #10
    Join Date
    Jul 2007
    Posts
    442

    Default Ouch! I need to disable pixel shaders AND vertex shaders!

    Quote Originally Posted by Zargoon View Post
    Oh I realize that having AIGLX and Composite may not make a difference at all I just did it at the same time that I disabled vertex shaders in wow. When vertex shaders are enabled it doesn't work right.
    So I get a completely black screen if I have

    SET pixelShaders "1"

    and I get a corrupt / incompletely rendered screen if I have

    SET M2UseShaders "1"

    However, I can at least use

    SET M2UsePixelShaders "1"

    The game is also refusing to run for me in D3D mode, and I've needed to disable the GL_ARB_vertex_buffer_objects extension for OpenGL mode via the Wine registry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •