Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 50

Thread: catalyst 11.9 is online ?

  1. #31
    Join Date
    Dec 2008
    Location
    San Bernardino, CA
    Posts
    231

    Default

    Well, its almost usable on my ATI4670 with Gnome Shell after enabling "tear free" desktop. Just a few graphical glitches every now and then. I really want to use FGLRX because I play a lot of Wine games; however, its back to the OSS drivers until catalyst 11.10 comes out.

  2. #32
    Join Date
    Dec 2008
    Posts
    86

    Default

    Quote Originally Posted by BlackStar View Post
    I can confirm that I get natural resolution on kernel terminals. This doesn't mean that it supports KMS, but something has definitely changed for the better here!

    Unfortunately, sleep is still broken on my dm1z. Back to the oss drivers which work correctly (if only they had better power saving on laptops...)
    see? I also tough that that wasn't kms infact vt switching isn't very fast... but this mean that we can use plymouth now?

  3. #33
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by DaemonFC View Post
    After some further investigation, 11.9 actually causes a regression for Kubuntu 11.10.

    X segfaults when Muon Software Center or Muon Package Manager prompts the user to enter their password.

    X segfaults when enabling or disabling kwin compositing.

    Also:

    Firefox now crashes instead of rendering upside down and backwards in OpenGL mode (which admittedly, you must force since they do warn that AM Catalyst is a broken driver, full of bugs)
    ooo wow... i'm so happy about that as a kde user (ironic),,

  4. #34
    Join Date
    Sep 2011
    Location
    Behind my CRT monitor
    Posts
    1

    Default Debian testing/unstable

    So there is no way to get 11.9 working in debian testing/unstable? I am using sid and was waiting for AMD to release a functional driver for 1.11.1 xorg-core.
    Maybe someone is using Gallium to get even basic 3d acceleration under X in similar situation?
    Thanks

  5. #35
    Join Date
    Aug 2011
    Posts
    78

    Default

    Just updated on Arch Linux, KDE4. No changes seen really. I rememember reading that some problems with were going to be fixed that helped with some problems in Minecraft (I think some incompatibilities in the JNI with FGLRX). Oh well...

  6. #36
    Join Date
    Feb 2010
    Posts
    519

    Default

    Hmm... So far I've gotten Spiral Knights to crash 3 times in 45 minutes with fglrx 11.9 and Oracle's JRE
    Code:
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  SIGSEGV (0xb) at pc=0x00007fc226e6c660, pid=20087, tid=140471944070912
    #
    # JRE version: 6.0_26-b03
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C  [fglrx_dri.so+0xeaf660]  ukiCreateContext+0xeaf660
    
    [snip]
    
    Current thread (0x00007fc234aa8800):  JavaThread "AWT-EventQueue-0" [_thread_in_native, id=20114, stack(0x00007fc22c43c000,0x00007fc22c53d000)]
    
    siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x0000000000000000
    I've switched back to OpenJDK for now (Which has the bad habit of randomly hardlocking the computer when loading maps... Rock or hard place... yay?)
    It might have been the same issue with 11.8 but I never got to test that version much since it made the interface flicker every now and then. Flickering is still there with 11.9 though happen much more seldom. 11.7 was fine.

    Then I launched Guild Wars through Wine 1.3.28 and 5 minutes in:
    Code:
    *--> Crash <--*
    Exception: c0000005 
    Memory at address 00000000 could not be written
    App: Gw.exe
    ProgramId: 1
    Build: 34484
    When: 9/30/2011 22:34:38
    Flags: 0
    First time I've ever gotten that.

    Is it me or it's the same error? (I've run memtest btw, no issue)
    Last edited by PsynoKhi0; 09-30-2011 at 06:42 PM.

  7. #37
    Join Date
    Mar 2011
    Posts
    38

    Default bottom right corner mouse

    Anyone know if the 'bottom right corner mouse hanging bug' is fixed?

  8. #38

    Default

    Quote Originally Posted by slojam View Post
    Anyone know if the 'bottom right corner mouse hanging bug' is fixed?
    It's fixed in Catalyst 11.8.

  9. #39

    Default

    If you have crash please report it here http://www.amd.com/us/LinuxCrewSurvey and here http://ati.cchtml.com
    Ubuntu, Kubuntu and openSUSE users also can contact with tech. support: http://emailcustomercare.amd.com

  10. #40
    Join Date
    Oct 2011
    Posts
    12

    Default

    Quote Originally Posted by DaemonFC View Post
    After some further investigation, 11.9 actually causes a regression for Kubuntu 11.10.

    X segfaults when Muon Software Center or Muon Package Manager prompts the user to enter their password.

    X segfaults when enabling or disabling kwin compositing.

    Also:

    Firefox now crashes instead of rendering upside down and backwards in OpenGL mode (which admittedly, you must force since they do warn that AM Catalyst is a broken driver, full of bugs)
    DaemonFC,

    I have the exact same problem with Fedora 15 and KDE 4.6. I completely removed the 11.8 fglrx modules before installing 11.9. I reinstalled 11.8.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •