Results 1 to 6 of 6

Thread: fglrx 8.32.5, opensuse 10.2 and x1900xt

  1. #1
    Join Date
    Dec 2006
    Posts
    17

    Default fglrx 8.32.5, opensuse 10.2 and x1900xt

    My son recently installed opensuse 10.2, latest drivers (8.32.5) on his machine with Radeon x1900xt... Drivers installs fine, and everythings shows correct version, there is hardware acceleration, but as soon he runs an opengl application (eg. fgl_glxgears) the screen gets a lot of artifacts, not so nice.

    I am only wondering if others has experiensed similar problems and/or if somebody got a solution?!

    I am running the same versions but with the difference of my card being Radeon 9800 ... and no artifacts on screen when running opengl!

  2. #2

    Default

    Quote Originally Posted by nesnomis View Post
    My son recently installed opensuse 10.2, latest drivers (8.32.5) on his machine with Radeon x1900xt... Drivers installs fine, and everythings shows correct version, there is hardware acceleration, but as soon he runs an opengl application (eg. fgl_glxgears) the screen gets a lot of artifacts, not so nice.

    I am only wondering if others has experiensed similar problems and/or if somebody got a solution?!

    I am running the same versions but with the difference of my card being Radeon 9800 ... and no artifacts on screen when running opengl!
    What options does he have set in his xorg.conf? I don't think I have heard of this problem with OpenSuSE 10.2.

  3. #3
    Join Date
    Dec 2006
    Posts
    17

    Default

    Quote Originally Posted by Michael View Post
    What options does he have set in his xorg.conf? I don't think I have heard of this problem with OpenSuSE 10.2.
    Thankyou for the reply!...

    It is the default
    Code:
    sax2 -r -m 0=fglrx
    generated xorg.conf.

    Device section here:

    Code:
    Section "Device"
      BoardName    "Framebuffer Graphics"
      BusID        "5:0:0"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "FSAADisableGamma" "no"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "CenterMode" "off"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "mtrr" "off"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "FSAAScale" "1"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "ForceGenericCPU" "no"
      Option       "GammaCorrectionI" "0x00000000"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "no_accel" "no"
      Option       "FSAACustomizeMSPos" "no"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "UseFastTLS" "0"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "BlockSignalsOnLock" "on"
      Option       "FSAAEnable" "no"
      Option       "KernelModuleParm" "locked-userpages=0"
      Option       "Capabilities" "0x00000000"
      Option       "VideoOverlay" "on"
      Option       "no_dri" "no"
      Option       "StereoSyncEnable" "1"
      Option       "PseudoColorVisuals" "off"
      Option       "UseInternalAGPGART" "no"
      Option       "FSAADisableGamma" "no"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "Capabilities" "0x00000000"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "OpenGLOverlay" "off"
      Option       "FSAAMSPosX2" "0.000000"
      Option       "Stereo" "off"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "CenterMode" "off"
      Option       "ScreenOverlap" "0"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "mtrr" "off"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "Stereo" "off"
      Option       "ForceGenericCPU" "no"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAScale" "1"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "GammaCorrectionI" "0x00000000"
      Option       "no_accel" "no"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "UseFastTLS" "0"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "FSAAMSPosX2" "0.000000"
      Option       "FSAACustomizeMSPos" "no"
      Option       "FSAAEnable" "no"
      Option       "BlockSignalsOnLock" "on"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "KernelModuleParm" "locked-userpages=0"
      Option       "no_dri" "no"
      Option       "VideoOverlay" "on"
      Option       "UseInternalAGPGART" "no"
      Option       "PseudoColorVisuals" "off"
      Option       "StereoSyncEnable" "1"
      Option       "OpenGLOverlay" "off"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "ScreenOverlap" "0"
      VendorName   "VESA"
    EndSection

  4. #4

    Default

    Does it work if you remove all of the options from the section, so it's very simple? Also, is fglrxinfo showing ATI Technologies?

  5. #5
    Join Date
    Dec 2006
    Posts
    17

    Default

    Quote Originally Posted by Michael View Post
    Does it work if you remove all of the options from the section, so it's very simple? Also, is fglrxinfo showing ATI Technologies?
    Yes we have tried that... And yes it shows ATI when running fglrxinf. Actually everything seems allrigt so it is a little strange, we have discussed eventually hardware failure, but the card works fine in windows... so.. probably not!?

  6. #6

    Default

    Instead of using sax2 try: aticonfig --initial -f to force the generation of an initial xorg.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •