Results 1 to 5 of 5

Thread: High power consumption with ATI 2900Pro and fglrx

  1. #1
    Join Date
    Oct 2007
    Location
    Tübingen/Germany
    Posts
    3

    Default High power consumption with ATI 2900Pro and fglrx

    Hi,
    I'm really happy about the new fglrx drivers and that my new Radeon HD 2900Pro works well in Linux. But yesterday I thought I should test my system's power consumption, because in Linux I can hear the cooler of the video card more often and running a lot faster/louder than in windows.
    There, the card clocks down when in 2D mode, and higher in 3D mode. Thus, the power consumtion is about 180W in idle and up to 300W during a game (overclocked to XT). Which is high, but I can live with that, cause I'm not playing all the time and in 2D mode I can undervolt the card so that the whole system needs only about 160W when idle. Undervolted or not, in windows the cooler is never hearable. But in Linux it's loud all the time and the electric meter confirms this: 230W when idle with 2900XT firmware and (what I do understand even less) with 2900Pro firmware, where the clock should be lower, it drags even 250W. 70W more than in Windows! Disabling AIGLX and Composite effects doesn't help, PowerPlay isn't available because of the driver or because the card doesn't support it. Thus atipower shouldn't work and rovclock hasn't any support for newer cards yet (saying "invalid reference clock from bios").

    So my question is: will there be a way to lower the gpu clock in the near future, e.g. with new fglrx drivers, better support in radeonhd drivers and/or tools like atipower and rovclock? For me, 3D in Linux isn't a must-have, because I'm using Windows for playing (and only for this) and "unfortunately" most of the time Linux for "working", where I could live without compiz. If only I could underclock this card. 70W is a lot when the computer runs at least half day, at least in Germany for a poor student
    Otherwise I have to take a closer look at the next 8800gt tests and consider selling my 2900pro. Perhaps this works better on nvidia's side? (though atm ati drivers make huge progresses!)

    I'd be happy if anyone has information about this issue!
    kind regards

  2. #2
    Join Date
    Oct 2007
    Posts
    10

    Default

    Ok i have some information for you...
    Unfortunately they are quite pessimistic.

    1. The Bug is known for over one year.
    2. Ati has done nothing in this time.

    I was really hopefull when 8.42.3 came out because they have rewritten the whole driver.
    But nothing happened and i dont think they will fix it in the near future.

    Maybe you should switch to nvidia
    I will switch when its time to buy a new card...

  3. #3
    Join Date
    Sep 2007
    Posts
    122

    Default

    Well, clock scaling doesn't have much to do with the OpenGL driver, so...

    Isn't it possible to *manually* clock down the GPU? See whether aticonfig --lsp offers you low power states.

  4. #4
    Join Date
    Oct 2007
    Location
    Tübingen/Germany
    Posts
    3

    Default

    Thanks for your posts!

    aticonfig --lsp says
    "Error: POWERplay is not supported on your hardware."
    Perhaps it will be in fglrx 8.69.3 or so, or, if this is really a hardware thing, it will never be supported by ati drivers.

    But at least after I disabled Compiz/AIGLX/Composite and did a reboot (last time a X-reboot didn't suffice), it consumes only 180W, as much as in Windows Vista in 2d mode. When gaming it needs more, and it goes down again afterwards. I think I can live with that, that is 'til my next graphics card buy
    Only gnome without compiz now seems a bit impractical to me, might switch back to e17 or the like...

  5. #5
    Join Date
    Nov 2007
    Posts
    7

    Default

    I am having a similar issue with x1650pro using latest driver. I guess now that 3D is working the GPU is getting hotter so the fan is running faster. As soon as I downgrade the driver, the fan speed goes back to normal, or at least fluctuates as and when needed rather than full-on all the time as it is now.

    aticonfig --lsp only offers one power state.

    Still, this is one step forward and two steps back, having upgraded from a very satisfactory SuSE 10.2 to 10.3 I'm closer to getting what I want but at the expense of stability or usability again thanks to Ati drivers (1680 x 1050 with Compiz on a Ati x1650Pro is like being back in Windows when VL bus cards started to appear and I was still running my trusty Trident).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •