The ati.amd website helpfully advises that:
The ATI Proprietary Linux driver currently supports Radeon 8500 and later AGP or PCI Express graphics products, as well as ATI FireGL 8700 and later products. We do not currently plan to include support for any products earlier than this.
but gives no indication or timeline of cards. Mine is a Radeon X1300 256MB - is this a before or after?