Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: Motherboards With Broken ASPM On Linux

  1. #31
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    90

    Default

    Quote Originally Posted by enihcam View Post
    http://forum.lenovo.com/t5/Linux-Dis...ng/td-p/560387

    Lenovo users, pls second this post.
    Yes, please support that!

  2. #32
    Join Date
    Oct 2009
    Posts
    218

    Default

    It would be great if someone tells to our poor souls how to manually detect if a motherboard has a faulty bios implementation and does not expose correctly pcie aspm.

    On my HP DV5 with AMD configuration (two years old notebook) adding pcie_aspm=force to my kernel boot options simply doesn't produce anything valuable in dmesg.
    The same happens on a HP Probook with an intel i3 sandy bridge processor (three months old notebook).

  3. #33

    Default

    Quote Originally Posted by Chewi View Post
    I think it should include servers. Electricity is a significant cost in running a server and not all servers push all their hardware to the maximum all the time. My own desktop is also my personal server that stays on all the time. This bug certainly matters to me.
    A busy server can only use so much electricity. It will not use more than it is rated for, no matter how busy. If it is sitting idle, or has only a small load it isn't designed right.

    Saving power in a data center is important of course, but ASPM isn't going to help out here.

  4. #34

    Default

    Quote Originally Posted by blackshard View Post
    It would be great if someone tells to our poor souls how to manually detect if a motherboard has a faulty bios implementation and does not expose correctly pcie aspm.

    On my HP DV5 with AMD configuration (two years old notebook) adding pcie_aspm=force to my kernel boot options simply doesn't produce anything valuable in dmesg.
    The same happens on a HP Probook with an intel i3 sandy bridge processor (three months old notebook).
    To see if you have a bad BIOS, look at /sys/module/pcie_aspm/parameters/policy. If it says 'default', you probably unfortunately have a computer that is reporting that ASPM is unsupported.

  5. #35

    Default

    Quote Originally Posted by Ex-Cyber View Post
    Looking at the Smolt statistics is always depressing. Even the mighty HP has lost the market share war to the up-and-coming "System manufacturer", thanks to the overwhelmingly popular "System Product Name System Version"
    They need better logic... Less than 0.5% of the systems being reported to OpenBenchmarking.org report a string like that, thanks to enough fallbacks.

  6. #36

    Default

    Quote Originally Posted by mdias View Post
    FFS, go cry to another corner! If you feel that only portable devices should be included, do us all a favour and give us the link to your filtered list.


  7. #37
    Join Date
    Oct 2011
    Posts
    9

    Thumbs down Gigabyte

    I have spoken with Gigabyte about broken ASPM and this was his response.

    Thank you for your kindly mail and inquiry. About the issue you mentioned, since our products only support Windows OS, we do not receive proper driver from chipset vender, we cannot guarantee Linux to work on our system. We suggest you to install Windows OS to prevent having problems. If you install the Windows OS and still have any problems, please provide the error message screenshot for us, so we can try to see how to help. Sorry for the inconvenience.

  8. #38
    Join Date
    Jun 2011
    Posts
    316

    Default

    Quote Originally Posted by Almorca View Post
    I have spoken with Gigabyte about broken ASPM and this was his response.

    Thank you for your kindly mail and inquiry. About the issue you mentioned, since our products only support Windows OS, we do not receive proper driver from chipset vender, we cannot guarantee Linux to work on our system. We suggest you to install Windows OS to prevent having problems. If you install the Windows OS and still have any problems, please provide the error message screenshot for us, so we can try to see how to help. Sorry for the inconvenience.
    So there you have it, basically Gigabyte themselves telling people not to buy their boards if people run anything other than Windows.

  9. #39
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,587

    Default

    Quote Originally Posted by Almorca View Post
    I have spoken with Gigabyte about broken ASPM and this was his response.

    Thank you for your kindly mail and inquiry. About the issue you mentioned, since our products only support Windows OS, we do not receive proper driver from chipset vender, we cannot guarantee Linux to work on our system. We suggest you to install Windows OS to prevent having problems. If you install the Windows OS and still have any problems, please provide the error message screenshot for us, so we can try to see how to help. Sorry for the inconvenience.
    You will get the same type of response from basically every vendor, except maybe tyan.

  10. #40
    Join Date
    May 2011
    Posts
    353

    Default

    Asus M4N68T LE V2 also affected, but now there's fixed kernels so it's not such a problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •