Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: No HDMI sound after upgrade to Kubuntu 11.10 with my hd4770

  1. #11
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by Kalavere View Post
    I realize this is for AMD/ATI and I am running Intel/Nvida, but is the principle the same for Nvida cards? I can't get any sound though HDMI with my GTX 550M.

    What would I need to write in place of Radeon?
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    Nvidia is different. I don't know if fermi still has "spdif" crossover cable, as previous generation, but you may want to look it up.
    Otherwise, its wrong thread to ask anyway.

  2. #12
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    isnt it much simpler to use nv binary drivers?

  3. #13
    Join Date
    Oct 2011
    Posts
    2

    Default

    Quote Originally Posted by crazycheese View Post
    Nvidia is different. I don't know if fermi still has "spdif" crossover cable, as previous generation, but you may want to look it up.
    Otherwise, its wrong thread to ask anyway.
    Thanks anyways. I've had trouble getting HDMI sound to work on 11.04, 11.10 and over two laptops. Never mind, I'll keep searching!

    Thanks again.

  4. #14
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    it is possible that you need to change one line in your default.pa - add the correct sink you found out which is working using "speaker-test -D hw:0,x -c2" - be sure all 4 possible spdif channels are unmuted (OO) with alsamixer. use nv binary driver. the x is the device number you get with "aplay -l". for onboard the card number is always 0, but of course not for a desktop system with dedicated gfx card.

  5. #15
    Join Date
    May 2011
    Posts
    353

    Default

    radeon.audio=1 is for the open-source driver, the proprietary driver doesn't use it. With nvidia you still need the proprietary driver for HDMI audio - Nouveau support for it won't come before the 3.2 or 3.3 kernel.
    Intel is a different matter. The HDMI audio is a codec chip connected to the onboard sound controller (or even integrated into it?), and the only thing that relates it to the graphics is that it happens to use the same HDMI connection for its output.

  6. #16
    Join Date
    Oct 2011
    Posts
    1

    Default No Sound

    Hi,
    My first time on this forum.
    I am having a similar problem - although I have an Intel i5 processor and HD 5700 series card. Everything was working fine in Kubuntu 11.04 but after upgrade to 11.10 no sound at all. Adding radeon.audio=1 to grub has made no difference.
    Any suggestions as to where else I should look?

    Thanks

  7. #17
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    136

    Default

    Same problem , i have amd 785g and amd 5450 no sound with kuibuntu 11.10.

  8. #18
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by agd5f View Post
    It's a module option, not a grub option. I'm not too familiar with grub2, but I think you would add it to GRUB_CMDLINE_LINUX_DEFAULT. e.g.,

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    now i do have killed the borg catalyst

    i also upgrade to 3.1 linux kernel and i also upgrade to oibaf radeon driver PPA

    but

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

    don't work? no sound...
    Last edited by Qaridarium; 10-28-2011 at 08:36 AM.

  9. #19
    Join Date
    May 2011
    Posts
    353

    Default

    After an edit to /etc/default/grub, you have to run sudo update-grub2 (or sudo update-grub).

  10. #20
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by AlbertP View Post
    After an edit to /etc/default/grub, you have to run sudo update-grub2 (or sudo update-grub).
    hey thank you... now i do have sound

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •