Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: No HDMI sound after upgrade to Kubuntu 11.10 with my hd4770

  1. #21
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

    after sudo update-grub2
    workssssssssssssss

    thanks

  2. #22
    Join Date
    Nov 2011
    Posts
    2

    Default

    why does the same functionality works with the catalyst ?

    in my point of view this can't be the source if the catalyst do not have the same black screen ...

    maybe they build an magic auto-detect ?

  3. #23
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    i dont use catalyst, ati free. I have 785g (radeon hd 4200) and hdmi work good with this grub patch.

  4. #24
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by ooHe0Eejem1 View Post
    why does the same functionality works with the catalyst ?

    in my point of view this can't be the source if the catalyst do not have the same black screen ...

    maybe they build an magic auto-detect ?
    its not a magic autodetect its a DRM UVD shit some displays force you to use this shit.

  5. #25
    Join Date
    Nov 2011
    Posts
    3

    Default No HDMI sound on ATI Radeon HD 5700 Series

    Hello,

    I'm on Arch Linux 64bit and use the open source radeon driver.

    Unfortunately I switched to the latest kernel *and* from proprietary catalyst driver to open source radeon driver, so I can't say whether it worked before the new kernel with the open source driver.

    lspci recognises the audio as
    Code:
    01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
    and I enabled radeon.audio=1 in menu.lst
    Code:
    kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/f16ef16a-2e5c-4725-97e0-9ae1f947c86f ro radeon.modeset=1 radeon.agpmode=-1 radeon.audio=1
    but I can't play back audio. When I try, the audio software plays back at incredible speed and no sound is there. mplayer, vlc, audacity, paplay, aplay, speaker-test all show the same behavior.
    pavucontrol however indicates a level change in the audio volume.

    My card is an Evergreen model and http://www.x.org/wiki/RadeonFeature indicates that HDMI audio is not supported for them. Although shouldn't lspci not be able to see it then?

  6. #26
    Join Date
    May 2011
    Posts
    353

    Default

    No, lspci devices always appear regardless of the driver used. The HDMI audio is just detected as a seperate chip, which also needs a driver to be loaded. It seems like Juniper HDMI Audio is not yet supported by snd-hda-intel.

  7. #27
    Join Date
    Jan 2009
    Posts
    148

    Default

    I'm currently experiencing the exact same as `qubodup`. I did add `radeon.audio=1` and ran update-grub, but it still doesn't work. Furthermore, audio plays at incredible speed (like qubodup reported).

    Is there a know fix for this behaviour?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •