Hi, I wanted to try Unigine on my Laptop, I'm a bit rusty when it comes to Linux, in fact the last couple of days I've been trying to get into things again, and yeah so far I'm happy with the result, it runs good, I tested my settings with GLXgears that gets a nice 5000FPS on my Llano based Laptop, however, when I try and run Unigine Heaven 2.0 or Sanctuary 2.3 I get the following error message if I run it through the terminal:


---- Render ----
GLRender::GLRender(): Unknown ATI GPU
OpenGL vendor: ATI Technologies Inc.
OpenGL renderer: AMD Radeon HD 6520G
OpenGL version: 1.4 (2.1 (4.1.11079 Compatibility Profile Context))

Unigine fatal error
Engine::init(): clear video settings for "AMD Radeon HD 6520G 1.4 (2.1 (4.1.11079 Compatibility Profile Context))"
GLRender::GLRender(): Unknown ATI GPU
GLRender::require_extension(): required extension GL_ARB_map_buffer_range is not supported
Shutdown

The thing I've suspected is, I updated my 11.04 to 11.10, installing the driver was all done on 11.04, so maybe I should just remove it, and install it the right way for 11.10, but then again, everything else seems to run fine, so I wanted to ask here first.

I tried googling it but didn't find any answers.