Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: F8 and X1300 with no display

  1. #1
    Join Date
    Nov 2007
    Posts
    10

    Default F8 and X1300 with no display

    HELP!

    I have reached my limit with this. I have a Panasonic CF-51 laptop with a 256MB X1300 card in it. I previously had FC5 installed and everything was excellent. Recently, I completely reinstalled the system with F7 and then F8. With F7 and F8, I can't get the graphical installer to work. When the install gets to the point where I should be picking keyboard layout, etc..., I get a blank screen and the system seems to be hung. CLT-ALT-BACKSPACE does nothing, etc... Only choice is to hard reboot.

    So I installed in text mode, then I used livna to get kmod-fglrx installed. Rebooted and get taken to a command line login. Running start X sends me back to the blank screen and everything is hung again.

    When I run fglrxinfo, I get an error: "Unable to open Display :0"! My Xorg log file shows no errors and the fglrx module seems to have loaded fine. I will include the log files below.

    Kernel version: Linux version 2.6.23.1-49.fc8. I have not done any yum updates, etc... so everything is stock F8 except for the video drivers.

    I appreciate any ideas/help that you can give. Also, I can post up the dmesg output or any other log files if they're helpfull. Thanks!

    Code:
    X Window System Version 1.3.0
    Release Date: 19 April 2007
    X Protocol Version 11, Revision 0, Release 1.3
    Build Operating System: Fedora Core 7 Red Hat, Inc.
    Current Operating System: Linux dooklap 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007 i686
    Build Date: 17 October 2007
    Build ID: xorg-x11-server 1.3.0.0-33.fc8 
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 11 17:02:58 2007
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Default Layout"
    (**) |-->Screen "aticonfig-Screen[0]" (0)
    (**) |   |-->Monitor "aticonfig-Monitor[0]"
    (**) |   |-->Device "aticonfig-Device[0]"
    (**) |-->Input Device "Keyboard0"
    (**) |-->Input Device "Synaptics"
    (II) No default mouse found, adding one
    (**) |-->Input Device "<default pointer>"
    (==) FontPath set to:
    	catalogue:/etc/X11/fontpath.d,
    	built-ins
    (==) RgbPath set to "/usr/share/X11/rgb"
    (==) ModulePath set to "/usr/lib/xorg/modules"
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) Loader magic: 0x820b5c0
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.3
    	X.Org Video Driver: 1.2
    	X.Org XInput driver : 0.7
    	X.Org Server Extension : 0.3
    	X.Org Font Renderer : 0.5
    (II) Loader running on linux
    (II) LoadModule: "pcidata"
    (II) Loading /usr/lib/xorg/modules//libpcidata.so
    (II) Module pcidata: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	ABI class: X.Org Video Driver, version 1.2
    (--) using VT number 7
    
    (II) PCI: PCI scan (all values are in hex)
    (II) PCI: 00:00:0: chip 8086,27a0 card 10f7,8338 rev 03 class 06,00,00 hdr 00
    (II) PCI: 00:01:0: chip 8086,27a1 card 0000,0000 rev 03 class 06,04,00 hdr 01
    (II) PCI: 00:1b:0: chip 8086,27d8 card 10f7,8338 rev 02 class 04,03,00 hdr 00
    (II) PCI: 00:1c:0: chip 8086,27d6 card 0000,0000 rev 02 class 06,04,00 hdr 81
    (II) PCI: 00:1c:2: chip 8086,27d4 card 0000,0000 rev 02 class 06,04,00 hdr 81
    (II) PCI: 00:1c:3: chip 8086,27d0 card 0000,0000 rev 02 class 06,04,00 hdr 81
    (II) PCI: 00:1d:0: chip 8086,27c8 card 10f7,8338 rev 02 class 0c,03,00 hdr 80
    (II) PCI: 00:1d:1: chip 8086,27c9 card 10f7,8338 rev 02 class 0c,03,00 hdr 00
    (II) PCI: 00:1d:2: chip 8086,27ca card 10f7,8338 rev 02 class 0c,03,00 hdr 00
    (II) PCI: 00:1d:3: chip 8086,27cb card 10f7,8338 rev 02 class 0c,03,00 hdr 00
    (II) PCI: 00:1d:7: chip 8086,27cc card 10f7,8338 rev 02 class 0c,03,20 hdr 00
    (II) PCI: 00:1e:0: chip 8086,2448 card 0000,0000 rev e2 class 06,04,01 hdr 01
    (II) PCI: 00:1f:0: chip 8086,27b9 card 10f7,8338 rev 02 class 06,01,00 hdr 80
    (II) PCI: 00:1f:2: chip 8086,27c4 card 10f7,8338 rev 02 class 01,01,80 hdr 00
    (II) PCI: 00:1f:3: chip 8086,27da card 10f7,8338 rev 02 class 0c,05,00 hdr 00
    (II) PCI: 01:00:0: chip 1002,7149 card 10f7,8338 rev 00 class 03,00,00 hdr 00
    (II) PCI: 03:00:0: chip 8086,4222 card 8086,1000 rev 02 class 02,80,00 hdr 00
    (II) PCI: 04:00:0: chip 11ab,4362 card 10f7,8338 rev 19 class 02,00,00 hdr 00
    (II) PCI: 05:00:0: chip 1180,0476 card 4000,0000 rev b1 class 06,07,00 hdr 82
    (II) PCI: 05:00:1: chip 1180,0476 card 4800,0000 rev b1 class 06,07,00 hdr 82
    (II) PCI: 05:00:2: chip 1180,0552 card 10f7,8338 rev 06 class 0c,00,10 hdr 80
    (II) PCI: 05:00:3: chip 1180,0822 card 10f7,8338 rev 15 class 08,05,00 hdr 80
    (II) PCI: End of PCI scan
    (II) Intel Bridge workaround enabled
    (II) Host-to-PCI bridge:
    (II) Bus 0: bridge is at (0:0:0), (0,0,7), BCTRL: 0x0008 (VGA_EN is set)
    (II) Bus 0 I/O range:
    	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) Bus 0 non-prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) Bus 0 prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) PCI-to-PCI bridge:
    (II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x001c (VGA_EN is set)
    (II) Bus 1 I/O range:
    	[0] -1	0	0x00002000 - 0x000020ff (0x100) IX[B]
    	[1] -1	0	0x00002400 - 0x000024ff (0x100) IX[B]
    	[2] -1	0	0x00002800 - 0x000028ff (0x100) IX[B]
    	[3] -1	0	0x00002c00 - 0x00002cff (0x100) IX[B]
    (II) Bus 1 non-prefetchable memory range:
    	[0] -1	0	0xf0000000 - 0xf00fffff (0x100000) MX[B]
    (II) Bus 1 prefetchable memory range:
    	[0] -1	0	0xe0000000 - 0xefffffff (0x10000000) MX[B]
    (II) PCI-to-PCI bridge:
    (II) Bus 2: bridge is at (0:28:0), (0,2,2), BCTRL: 0x0004 (VGA_EN is cleared)
    (II) PCI-to-PCI bridge:
    (II) Bus 3: bridge is at (0:28:2), (0,3,3), BCTRL: 0x0004 (VGA_EN is cleared)
    (II) Bus 3 non-prefetchable memory range:
    	[0] -1	0	0xf0100000 - 0xf01fffff (0x100000) MX[B]
    (II) PCI-to-PCI bridge:
    (II) Bus 4: bridge is at (0:28:3), (0,4,4), BCTRL: 0x0004 (VGA_EN is cleared)
    (II) Bus 4 I/O range:
    	[0] -1	0	0x00003000 - 0x000030ff (0x100) IX[B]
    	[1] -1	0	0x00003400 - 0x000034ff (0x100) IX[B]
    	[2] -1	0	0x00003800 - 0x000038ff (0x100) IX[B]
    	[3] -1	0	0x00003c00 - 0x00003cff (0x100) IX[B]
    (II) Bus 4 non-prefetchable memory range:
    	[0] -1	0	0xf0200000 - 0xf02fffff (0x100000) MX[B]
    (II) Bus 4 prefetchable memory range:
    	[0] -1	0	0x90000000 - 0x900fffff (0x100000) MX[B]
    (II) Subtractive PCI-to-PCI bridge:
    (II) Bus 5: bridge is at (0:30:0), (0,5,10), BCTRL: 0x0004 (VGA_EN is cleared)
    (II) Bus 5 I/O range:
    	[0] -1	0	0x00004000 - 0x000040ff (0x100) IX[B]
    	[1] -1	0	0x00004400 - 0x000044ff (0x100) IX[B]
    	[2] -1	0	0x00004800 - 0x000048ff (0x100) IX[B]
    	[3] -1	0	0x00004c00 - 0x00004cff (0x100) IX[B]
    (II) Bus 5 non-prefetchable memory range:
    	[0] -1	0	0xf0300000 - 0xf03fffff (0x100000) MX[B]
    (II) Bus 5 prefetchable memory range:
    	[0] -1	0	0x88000000 - 0x8fffffff (0x8000000) MX[B]
    (II) PCI-to-ISA bridge:
    (II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
    (II) PCI-to-CardBus bridge:
    (II) Bus 6: bridge is at (5:0:0), (5,6,6), BCTRL: 0x0580 (VGA_EN is cleared)
    (II) Bus 6 I/O range:
    	[0] -1	0	0x00004000 - 0x000040ff (0x100) IX[B]
    	[1] -1	0	0x00004400 - 0x000044ff (0x100) IX[B]
    (II) Bus 6 prefetchable memory range:
    	[0] -1	0	0x88000000 - 0x8bffffff (0x4000000) MX[B]
    (II) PCI-to-CardBus bridge:
    (II) Bus 7: bridge is at (5:0:1), (5,7,10), BCTRL: 0x0580 (VGA_EN is cleared)
    (II) Bus 7 I/O range:
    	[0] -1	0	0x00004800 - 0x000048ff (0x100) IX[B]
    	[1] -1	0	0x00004c00 - 0x00004cff (0x100) IX[B]
    (II) Bus 7 prefetchable memory range:
    	[0] -1	0	0x8c000000 - 0x8fffffff (0x4000000) MX[B]
    (--) PCI:*(1:0:0) ATI Technologies Inc M52 [ATI Mobility Radeon X1300] rev 0, Mem @ 0xe0000000/28, 0xf0000000/16, I/O @ 0x2000/8
    Last edited by bp787; 11-13-2007 at 09:10 AM.

  2. #2
    Join Date
    Nov 2007
    Posts
    10

    Default

    More Xorg log: ( I cut some of the resource ranges out for space...

    Code:
    (II) Addressable bus resource ranges are
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) OS-reported resource ranges:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) Active PCI resource ranges:
    	[0] -1	0	0xf0302800 - 0xf03028ff (0x100) MX[B]
    	[1] -1	0	0xf0302000 - 0xf03027ff (0x800) MX[B]
    	[2] -1	0	0xf0200000 - 0xf0203fff (0x4000) MX[B]
    	[3] -1	0	0xf0100000 - 0xf0100fff (0x1000) MX[B]
    	[4] -1	0	0xf0604000 - 0xf06043ff (0x400) MX[B]
    	[5] -1	0	0xf0600000 - 0xf0603fff (0x4000) MX[B]
    	[6] -1	0	0xf0000000 - 0xf000ffff (0x10000) MX[B](B)
    	[7] -1	0	0xe0000000 - 0xefffffff (0x10000000) MX[B](B)
    	[8] -1	0	0x00003000 - 0x000030ff (0x100) IX[B]
    	[9] -1	0	0x00001860 - 0x0000187f (0x20) IX[B]
    	[10] -1	0	0x000018d0 - 0x000018df (0x10) IX[B]
    	[11] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[12] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[13] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[14] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[15] -1	0	0x00001880 - 0x0000189f (0x20) IX[B]
    	[16] -1	0	0x00001840 - 0x0000185f (0x20) IX[B]
    	[17] -1	0	0x00001820 - 0x0000183f (0x20) IX[B]
    	[18] -1	0	0x00001800 - 0x0000181f (0x20) IX[B]
    	[19] -1	0	0x00002000 - 0x000020ff (0x100) IX[B](B)
    (II) Active PCI resource ranges after removing overlaps:
    	[0] -1	0	0xf0302800 - 0xf03028ff (0x100) MX[B]
    	[1] -1	0	0xf0302000 - 0xf03027ff (0x800) MX[B]
    	[2] -1	0	0xf0200000 - 0xf0203fff (0x4000) MX[B]
    	[3] -1	0	0xf0100000 - 0xf0100fff (0x1000) MX[B]
    	[4] -1	0	0xf0604000 - 0xf06043ff (0x400) MX[B]
    	[5] -1	0	0xf0600000 - 0xf0603fff (0x4000) MX[B]
    	[6] -1	0	0xf0000000 - 0xf000ffff (0x10000) MX[B](B)
    	[7] -1	0	0xe0000000 - 0xefffffff (0x10000000) MX[B](B)
    	[8] -1	0	0x00003000 - 0x000030ff (0x100) IX[B]
    	[9] -1	0	0x00001860 - 0x0000187f (0x20) IX[B]
    	[10] -1	0	0x000018d0 - 0x000018df (0x10) IX[B]
    	[11] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[12] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[13] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[14] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[15] -1	0	0x00001880 - 0x0000189f (0x20) IX[B]
    	[16] -1	0	0x00001840 - 0x0000185f (0x20) IX[B]
    	[17] -1	0	0x00001820 - 0x0000183f (0x20) IX[B]
    	[18] -1	0	0x00001800 - 0x0000181f (0x20) IX[B]
    	[19] -1	0	0x00002000 - 0x000020ff (0x100) IX[B](B)
    (II) OS-reported resource ranges after removing overlaps with PCI:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) All system resource ranges:
    	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0xf0302800 - 0xf03028ff (0x100) MX[B]
    	[5] -1	0	0xf0302000 - 0xf03027ff (0x800) MX[B]
    	[6] -1	0	0xf0200000 - 0xf0203fff (0x4000) MX[B]
    	[7] -1	0	0xf0100000 - 0xf0100fff (0x1000) MX[B]
    	[8] -1	0	0xf0604000 - 0xf06043ff (0x400) MX[B]
    	[9] -1	0	0xf0600000 - 0xf0603fff (0x4000) MX[B]
    	[10] -1	0	0xf0000000 - 0xf000ffff (0x10000) MX[B](B)
    	[11] -1	0	0xe0000000 - 0xefffffff (0x10000000) MX[B](B)
    	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[14] -1	0	0x00003000 - 0x000030ff (0x100) IX[B]
    	[15] -1	0	0x00001860 - 0x0000187f (0x20) IX[B]
    	[16] -1	0	0x000018d0 - 0x000018df (0x10) IX[B]
    	[17] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[18] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[19] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[20] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[21] -1	0	0x00001880 - 0x0000189f (0x20) IX[B]
    	[22] -1	0	0x00001840 - 0x0000185f (0x20) IX[B]
    	[23] -1	0	0x00001820 - 0x0000183f (0x20) IX[B]
    	[24] -1	0	0x00001800 - 0x0000181f (0x20) IX[B]
    	[25] -1	0	0x00002000 - 0x000020ff (0x100) IX[B](B)
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules//extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension SHAPE
    (II) Loading extension MIT-SUNDRY-NONSTANDARD
    (II) Loading extension BIG-REQUESTS
    (II) Loading extension SYNC
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XC-MISC
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-Misc
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension TOG-CUP
    (II) Loading extension Extended-Visual-Information
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules//extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules//extensions/libglx.so
    (II) Module glx: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (==) AIGLX enabled
    (II) Loading extension GLX
    (II) LoadModule: "freetype"
    (II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
    (II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
    	compiled for 1.3.0, module version = 2.1.0
    	Module class: X.Org Font Renderer
    	ABI class: X.Org Font Renderer, version 0.5
    (II) Loading font FreeType
    (II) LoadModule: "type1"
    (II) Loading /usr/lib/xorg/modules//fonts/libtype1.so
    (II) Module type1: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.2
    	Module class: X.Org Font Renderer
    	ABI class: X.Org Font Renderer, version 0.5
    (II) Loading font Type1
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules//extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.13.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules//extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules//drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.42.3
    	Module class: X.Org Video Driver
    (II) LoadModule: "kbd"
    (II) Loading /usr/lib/xorg/modules//input/kbd_drv.so
    (II) Module kbd: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.2.2
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.7
    (II) LoadModule: "synaptics"
    (II) Loading /usr/lib/xorg/modules//input/synaptics_drv.so
    (II) Module synaptics: vendor="X.Org Foundation"
    	compiled for 4.3.99.902, module version = 1.0.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.7
    (II) LoadModule: "mouse"
    (II) Loading /usr/lib/xorg/modules//input/mouse_drv.so
    (II) Module mouse: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 1.2.3
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.7
    (II) Primary Device is: PCI 01:00:0
    (II) ATI Proprietary Linux Driver Version Identifier:8.42.3
    (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.423.2                  
    (II) ATI Proprietary Linux Driver Build Date: Oct 19 2007 16:13:26
    (--) Assigning device section with no busID to primary device
    (--) Chipset Supported AMD Graphics Processor (0x7149) found
    (II) AMD Video driver is running on a device belonging to a group targeted for this release
    (II) AMD Video driver is signed
    (II) resource ranges after xf86ClaimFixedResources() 
    (II) Setting vga for screen 0.
    (II) Enabling PCI device
    (II) fglrx(0): === [atiddxPreInit] === begin, [x]
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"
    (II) Loading /usr/lib/xorg/modules//libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    	compiled for 1.3.0, module version = 0.1.0
    	ABI class: X.Org Video Driver, version 1.2
    (II) fglrx(0): PCI bus 1 card 0 func 0
    (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
    (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) fglrx(0): Default visual is TrueColor
    (**) fglrx(0): Option "UseInternalAGPGART" "no"
    (**) fglrx(0): Option "DPMS" "true"
    (==) fglrx(0): RGB weight 888
    (II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
    (==) fglrx(0): Gamma Correction for I is 0x06419064
    (==) fglrx(0): Gamma Correction for II is 0x06419064
    (==) fglrx(0): Buffer Tiling is ON
    (--) fglrx(0): Chipset: "ATI Mobility Radeon X1300" (Chipset = 0x7149)
    (--) fglrx(0): (PciSubVendor = 0x10f7, PciSubDevice = 0x8338)
    (--) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
    (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
    (--) fglrx(0): MMIO registers at 0xf0000000
    (==) fglrx(0): ROM-BIOS at 0x000c0000

  3. #3
    Join Date
    Nov 2007
    Posts
    10

    Default

    Xorg.conf:

    Code:
    # Xorg configuration created by pyxf86config
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    	InputDevice    "Synaptics" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us+inet"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Synaptics"
    	Driver      "synaptics"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "auto-dev"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "vesa"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option "UseInternalAGPGART" "no"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection

  4. #4
    Join Date
    Jun 2007
    Posts
    63

    Default

    Quote Originally Posted by bp787 View Post
    HELP!

    With F7 and F8, I can't get the graphical installer to work. When the install gets to the point where I should be picking keyboard layout, etc..., I get a blank screen and the system seems to be hung. CLT-ALT-BACKSPACE does nothing, etc... Only choice is to hard reboot.

    [/CODE]
    You mean you booted from the install DVD and could not get past the first few screens? Strange. Did you check forums.fedoraforum.org whether this is a known problem?

    Quote Originally Posted by bp787 View Post
    HELP!

    Kernel version: Linux version 2.6.23.1-49.fc8. I have not done any yum updates, etc... so everything is stock F8 except for the video drivers.

    [/CODE]
    Then why is your kernel not 2.6.23.1-42, as that's the one that comes with the F8 DVD?

    Does the card work with the vesa drivers?

    Did you try "aticonfig --initial"?

  5. #5
    Join Date
    Nov 2007
    Posts
    10

    Default

    Quote Originally Posted by Christian_L View Post
    You mean you booted from the install DVD and could not get past the first few screens? Strange. Did you check forums.fedoraforum.org whether this is a known problem?
    I booted from the DVD, I selected the first option (normal GUI install), and it runs through the normal startup stuff (all text). When it gets to where the GUI should come up and start asking for Keyboard type, etc..., I get a blank screen, and nothing else works.


    Quote Originally Posted by Christian_L View Post
    Then why is your kernel not 2.6.23.1-42, as that's the one that comes with the F8 DVD?

    Does the card work with the vesa drivers?

    Did you try "aticonfig --initial"?

    The new kernel was created when I installed kmod-fglrx from livna.

    The card didn't work prior to installing kmod-fglrx, which would have been the default vesa drivers. I tried the vesa drivers in F7 with the same effect... black screen.

    aticonfig --initial does nothing because fglrx is already found due to livna setting up the xorg.conf file.

  6. #6
    Join Date
    Nov 2007
    Posts
    10

    Default

    bump for help...

  7. #7
    Join Date
    Jun 2007
    Posts
    63

    Default

    If it does neither work with vesa drivers nor with the installation CD, then I would assume that it's not an fglrx problem, but that F8 has some general problems of identifying your display. So it's probably better to search/ask in the Ffedora forums for people with similar experiences.

  8. #8
    Join Date
    Dec 2006
    Posts
    82

    Default

    I've installed F7/F8 on my mobility X1300 and then X1400 .

    I am confused by your post.

    You say you couldn't install graphically. But you have logs with f7 tags in them. Did you end up doing a text-only install? That may not install all the graphics stuff by default(Guessing; shot in dark).

    I'd try to see why anaconda isn't recognizing your video setup. After the initial stuff(ncurses-style gui) goes away; anaconda ussually comes up with something to the effect of:
    Videocard: your video card
    Monitor: your monitorc

    What does this look like for you?
    Also did the media-check pass and/or md5sum checkout after download?

    Back in the day, I know the DDC information coming from my monitor was incorrect and would fub up all linux liveCDs and installers. You could try passing the "skipddc" argument at boot-time(in the installer)..

    So throw in the disc, wait for the menu, hit esc, then type in "linux skipddc".

  9. #9
    Join Date
    Nov 2007
    Posts
    10

    Default

    Quote Originally Posted by koolmanoncampus View Post
    I've installed F7/F8 on my mobility X1300 and then X1400 .

    I am confused by your post.

    You say you couldn't install graphically. But you have logs with f7 tags in them. Did you end up doing a text-only install? That may not install all the graphics stuff by default(Guessing; shot in dark).

    I'd try to see why anaconda isn't recognizing your video setup. After the initial stuff(ncurses-style gui) goes away; anaconda ussually comes up with something to the effect of:
    Videocard: your video card
    Monitor: your monitorc

    What does this look like for you?
    Also did the media-check pass and/or md5sum checkout after download?

    Back in the day, I know the DDC information coming from my monitor was incorrect and would fub up all linux liveCDs and installers. You could try passing the "skipddc" argument at boot-time(in the installer)..

    So throw in the disc, wait for the menu, hit esc, then type in "linux skipddc".


    The only way i could get either f7 or f8 to install was using the text method.

    As for the anaconda stuff, are you talking about during install or during boot?

    I'll have to go back and look tomorrow.

    media checks out fine for both my f7 and f8 discs.

    Also, what do you mean by "logs with f7 tags in them?


    I'm actually leaning more towards this not being solely a video driver problem. It's really strange to me that fc5 works fine on this but later versions are broken.

  10. #10
    Join Date
    Nov 2007
    Posts
    10

    Default

    Quote Originally Posted by Christian_L View Post
    If it does neither work with vesa drivers nor with the installation CD, then I would assume that it's not an fglrx problem, but that F8 has some general problems of identifying your display. So it's probably better to search/ask in the Ffedora forums for people with similar experiences.
    will checkout fedoraforums then...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •