Results 1 to 6 of 6

Thread: Unable to boot distros post kernel 3 on radeon hd 6790

  1. #1
    Join Date
    Jun 2009
    Location
    NCD - Ireland
    Posts
    17

    Question Unable to boot distros post kernel 3 on radeon hd 6790

    I have an issue that currently affects new dstros. The current distros boot to the live desktop but the image is garbled. It clearly shows the garbled image of my win 7 desktop as if it remained as an image in the gpu memory. I have tried many different ways to get a distro to boot. Currently trying ubuntu 11.10 so if any one has any ideas throw them at me.
    Tried:

    radeon.modeset=0
    radeon.modeset=1
    nomodeset
    acpi=force
    "acpi_osi " ("" to show space)
    So any other suggestions would be welcome.

    Ger.

  2. #2
    Join Date
    Jul 2011
    Posts
    74

    Default

    Are you sure there isn't something wrong with your display or graphics card? Does Windows display properly?

  3. #3
    Join Date
    Jun 2009
    Location
    NCD - Ireland
    Posts
    17

    Default

    Hi
    The card is fine - works perfectly in windows and indeed in mint 11
    This happens across two different mobos and also affected the ati 4200 onboard on the other board.
    I was using opensuse tumbleweed and aafter updating the kernel past 3 I had the same issue

  4. #4
    Join Date
    Jun 2009
    Location
    NCD - Ireland
    Posts
    17

    Default Solved issue!

    I've nailed it!!

    acpi=off and it boots

    I tried it on the off chancwe when I remembered the Dell laptop I had needed it way back and bingo! 11.04 installed and booting.....

    So now to see if this will work with 11.10 - should do!!

  5. #5
    Join Date
    Jun 2009
    Location
    NCD - Ireland
    Posts
    17

    Default or not so solved!

    Seems I still have the issue in 11.10 - garbled screen and no desktop above has no impact.

  6. #6
    Join Date
    Jun 2009
    Location
    NCD - Ireland
    Posts
    17

    Default workaround

    I have identified the open source readeon driver as the cause

    if I boot ubuntu 11.10 with nomodeset blacklist=radeon 3
    then in tty apt-get install fglrx
    apt-get update
    startx
    I was able to reach the desktop and install, although I had to repeat the process post install
    After which I was there up to the point where there is an issue with the realtek lan lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •