Results 1 to 5 of 5

Thread: ATI Catalyst 9.8 Xorg freeze when idle

  1. #1

    Default ATI Catalyst 9.8 Xorg freeze when idle

    Hi,
    I have installed catalyst 9.8 in my arch system with radeon HD 4850. I suffer from Xorg freezes. I leave my computer for several minutes, then go back and screen is blank, and there is no signal. REISUB sequence does the work.
    I used to use ati open source driver but now I need it to use HDMI and audio over HDMI.
    Does anyone know the solution?

  2. #2
    Join Date
    Mar 2009
    Posts
    174

    Default

    Pray that they poach some nVidia driver developers soon...

    Other than that if you're using Compiz/beryl (sometimes known as desktop effects) turn them ALL OFF, as this "fixed" my freeze when awaking from sleep and a couple of other things...

    Beyond that we all just sit around waiting for either the OSS drivers to catch up to current architectures and actually be good(bridgman says they're already better than the proprietary for 2D) or wait for something awful to happen at AMD and they actually release a quality catalyst for linux + X.org...
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  3. #3
    Join Date
    Mar 2008
    Location
    Istanbul
    Posts
    134

    Default

    I got same thing with using kernel 2.6.27.
    I upgrade my kernel to 2.6.31-rc7 and all hangups are gone.
    You need to modify fglrx kernel code with patch for make compatible with 2.6.31.

  4. #4
    Join Date
    Jun 2011
    Posts
    3

    Default Sorry, because this might look like a zombie resurrection post, but it is not.

    I had similar problem as the described one (ATI Radeon laptop + Compiz resulting in complete lock up after exactly 20 minutes idle time).
    I searched the web in all directions and was unable to find any clue, but suddenly I resolved it. The problem was simple to deal with, but it took a long time to find out what's going on. As I forementioned I'm using Compiz. I ticked all the boxes in Compiz workarounds plugin, and the lock-up problem is gone.

    I am writing, because I couldn't find any recipe anywhere on the internet, the problem persisted with every Catalyst version I could test (10.x, 11.x up to 11.9), so I think it might be useful for somebody having same issues.

    So forgive me waking up a zombie thread. ;-)

  5. #5
    Join Date
    Jun 2011
    Posts
    3

    Default

    One more detail I've found is that "tear free" option in Catalyst configuration has to be disabled also.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •