Results 1 to 4 of 4

Thread: FGLRX 8.43.2 - Cursor Corruption.

  1. #1
    Join Date
    Oct 2007
    Posts
    321

    Default FGLRX 8.43.2 - Cursor Corruption.

    i'm having issues with repeated cursor corruption on my screen... it occurs mainly when i have firefox running and a flash animation is on the page for the most part... here's the device section of my Xorg, have any ideas on what to enable to fix this, oh and keep in mind that i don't want video issues.

    Code:
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	# CRT 1 for main, and TV out for second monitor.
    	Option	    "EnableMonitor" "crt1,tv"
    	Option	    "FSAAScale" "0"
    	Option	    "FSAAEnable" "off"
    	Option	    "StereoSyncEnable" "off"
    	Option	    "Stereo" "off"
    	Option	    "UseFastTLS" "off"
    	Option	    "BlockSignalsOnLock" "off"
    	BusID       "PCI:5:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[1]"
    	Driver      "fglrx"
    	BusID       "PCI:5:0:0"
    	Screen      1
    EndSection

  2. #2
    Join Date
    Dec 2007
    Location
    United Kingdom
    Posts
    54

    Default

    I think you need to add:

    Option "XAANoOffscreenPixmaps" "on"

    to your Device section(s).

  3. #3
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    It may be "true", rather than "on"... not sure if it will respond to both.

    The above suggestion is correct, by the way... it solved my display corruption problem on a Mobility X1400.

  4. #4
    Join Date
    Oct 2007
    Posts
    321

    Default

    seems to be working now... i have not seen any issues with it since i set that on both device sections, oh and is there any suggestions to the config file to fix crashing issues with opengl?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •