Results 1 to 6 of 6

Thread: vdpau with archbang

  1. #1
    Join Date
    Nov 2011
    Posts
    10

    Default vdpau with archbang

    on ubuntu 11.10, nvidia 280, and a quadro 600 ( VDPAU Feature Sets C ),
    there is a slight stutter of the video (hd video)

    same problem with xubuntu, lubuntu, fedora, mint.

    But, no artefacts at all with archbang.

    media player : vlc

  2. #2
    Join Date
    Oct 2011
    Posts
    2

    Default

    Please disable desktop effects (--no-composite) and try. what command you are using to play mplayer ?, Are you using latest mplayer ?
    Attach video you are using.

  3. #3
    Join Date
    Nov 2011
    Posts
    10

    Default

    Quote Originally Posted by sandipt View Post
    Please disable desktop effects (--no-composite) and try. what command you are using to play mplayer ?, Are you using latest mplayer ?
    Attach video you are using.
    I do not use mplayer (as specified) but vlc.
    and xubuntu is not a GL-enabled desktops, but the ugly line continues to rise unexpectedly.

    curiously, in ubuntu 11.04, the display of videos was impeccable, ONLY when compiz was ON !!!!!

  4. #4
    Join Date
    Nov 2011
    Posts
    10

    Default ok

    Quote Originally Posted by sandipt View Post
    Please disable desktop effects (--no-composite) and try. what command you are using to play mplayer ?, Are you using latest mplayer ?
    Attach video you are using.
    You was right : when enabling compiz on ArchBang, the ugly lines arise again when watching video.


    I guess, even with a quadro 600, 6go ram, Q9550, i need a primitive WM like openbox, with no compiz loaded, and with no fancy effects like transparency !!!!

  5. #5
    Join Date
    Jan 2011
    Posts
    193

    Default

    Quote Originally Posted by letocha View Post
    on ubuntu 11.10, nvidia 280, and a quadro 600 ( VDPAU Feature Sets C ),
    there is a slight stutter of the video (hd video)

    same problem with xubuntu, lubuntu, fedora, mint.

    But, no artefacts at all with archbang.

    media player : vlc
    I believe you need to install libva or vdpau-video, because vlc does not use vdpau directly, but needs some sort of backend installed for vaapi. (which I believe has a backend which defaults to either the x or gl shader acceleration method). Also Hardware acceleration in vlc on some distros is not flipped on by default.
    Last edited by WorBlux; 11-16-2011 at 12:17 PM.

  6. #6
    Join Date
    Aug 2007
    Posts
    6,623

    Default

    Basically using the vdpau-video wrapper is not that good, it does not even work with xbmc correctly which supports vdpau + vaapi. vlc could only use vaapi when the ffmpeg/libav used was single threaded, otherwise it was disabled anyway because it immediately crashed. For native vdpau i would always use xmbc or mplayer2. mplayer2 can use the vdpau rendering too, needs vc override to use it for decode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •