Results 1 to 3 of 3

Thread: Installing AMD 8.42.3 drivers, but having problems

  1. #1
    Join Date
    Nov 2007
    Posts
    2

    Default Installing AMD 8.42.3 drivers, but having problems

    Hi, I'm a new Linux user using Ubuntu Gutsy (just installed it). The computer I'm working with is an old Hypersonic Aviator ZX7, 2.8ghz P4, 1gig RAM, with a ATI Radeon Mobility Pro 9600 graphics card.

    I'm unable to run the visual effects; when I try to activate them, I get an error message saying that "The Composite extension is not availible".

    I'm trying now to install the new AMD/ATI drivers using this walkthrough: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    Method 1 didn't work, so I'm going through Method 2. Everything is going fine until I get to this command and results:

    Code:
    david@Hypersonic:~$ sudo dpkg -i xorg-driver-fglrx 8.42.3-1*.deb \
    > fglrx-kernel-source_8.42.3-1*.deb \
    > fglrx-amdcccle_8.42.3-1*.deb
    dpkg: error processing xorg-driver-fglrx (--install):
     cannot access archive: No such file or directory
    dpkg: error processing 8.42.3-1*.deb (--install):
     cannot access archive: No such file or directory
    Selecting previously deselected package fglrx-kernel-source.
    (Reading database ... 117896 files and directories currently installed.)
    Unpacking fglrx-kernel-source (from fglrx-kernel-source_8.42.3-1_i386.deb) ...
    Selecting previously deselected package fglrx-amdcccle.
    Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.42.3-1_i386.deb) ...
    dpkg: error processing fglrx-amdcccle_8.42.3-1_i386.deb (--install):
     trying to overwrite `/usr/bin/amdcccle', which is also in package xorg-driver-fglrx
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Setting up fglrx-kernel-source (8.42.3-1) ...
    Errors were encountered while processing:
     xorg-driver-fglrx
     8.42.3-1*.deb
     fglrx-amdcccle_8.42.3-1_i386.deb
    If I try to proceed anyway:

    Code:
    david@Hypersonic:~$ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I am a noob at this, so any help is greatly appreciated. I did some searching around here, but couldn't find anything, but maybe I'm searching for the wrong things.

  2. #2
    Join Date
    Oct 2007
    Posts
    46

    Default

    Quote Originally Posted by morgond View Post
    Hi, I'm a new Linux user using Ubuntu Gutsy (just installed it). The computer I'm working with is an old Hypersonic Aviator ZX7, 2.8ghz P4, 1gig RAM, with a ATI Radeon Mobility Pro 9600 graphics card.

    I'm unable to run the visual effects; when I try to activate them, I get an error message saying that "The Composite extension is not availible".

    I'm trying now to install the new AMD/ATI drivers using this walkthrough: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    Method 1 didn't work, so I'm going through Method 2. Everything is going fine until I get to this command and results:

    Code:
    david@Hypersonic:~$ sudo dpkg -i xorg-driver-fglrx 8.42.3-1*.deb \
    > fglrx-kernel-source_8.42.3-1*.deb \
    > fglrx-amdcccle_8.42.3-1*.deb
    dpkg: error processing xorg-driver-fglrx (--install):
     cannot access archive: No such file or directory
    dpkg: error processing 8.42.3-1*.deb (--install):
     cannot access archive: No such file or directory
    Selecting previously deselected package fglrx-kernel-source.
    (Reading database ... 117896 files and directories currently installed.)
    Unpacking fglrx-kernel-source (from fglrx-kernel-source_8.42.3-1_i386.deb) ...
    Selecting previously deselected package fglrx-amdcccle.
    Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.42.3-1_i386.deb) ...
    dpkg: error processing fglrx-amdcccle_8.42.3-1_i386.deb (--install):
     trying to overwrite `/usr/bin/amdcccle', which is also in package xorg-driver-fglrx
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Setting up fglrx-kernel-source (8.42.3-1) ...
    Errors were encountered while processing:
     xorg-driver-fglrx
     8.42.3-1*.deb
     fglrx-amdcccle_8.42.3-1_i386.deb
    If I try to proceed anyway:

    Code:
    david@Hypersonic:~$ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I am a noob at this, so any help is greatly appreciated. I did some searching around here, but couldn't find anything, but maybe I'm searching for the wrong things.

    The fix is simple - there's a typo in your instruction... you're missing an underscore between
    xorg-driver-fglrx and 8.42 - it should all be one word, representing that particular deb file.

  3. #3
    Join Date
    Nov 2007
    Posts
    2

    Default

    I knew it had to be something simple I was missing. :P dumb is me. Ok, so that worked, but now when I get down to this command:

    Code:
    sudo module-assistant build,install fglrx -f
    It tries to build it, but I get the following error in the module-assistant, interactive mode window:

    "Build of the package fglrx-kernel-source failed! How do you wish to proceed?"

    If I VIEW the build log file, here's what it says:

    Code:
    dh_testroot                                                                
    rm -f configure-stamp                                                      
    rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a                               
    rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd                        
    rm -rf .tmp_versions                                                       
    rm -rf patch                                                               
    dh_clean                                                                   
    rm /usr/src/modules/fglrx/debian/control                                   
    rm /usr/src/modules/fglrx/debian/dirs                                      
    if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \   
            cat /usr/src/modules/fglrx/debian/control.template >               
    /usr/src/modules/fglrx/debian/control; \                                   
            fi                                                                 
    if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \                   
            mv /usr/src/modules/fglrx/debian/postinst
            fi                                                                 
    dh_testdir                                                                 
    touch configure-stamp                                                      
    dh_testdir                                                                 
    /usr/bin/make -C /usr/src/linux SUBDIRS=/usr/src/modules/fglrx modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-rt'
       CC [M]  /usr/src/modules/fglrx/firegl_public.o                           
    /usr/src/modules/fglrx/firegl_public.c:365: warning: initialization from incompatible pointer type                                                  
    /usr/src/modules/fglrx/firegl_public.c:366: warning: initialization from incompatible pointer type                                                  
    /usr/src/modules/fglrx/firegl_public.c: In function ‘fglrx_pci_suspend’:  
    /usr/src/modules/fglrx/firegl_public.c:799: warning: passing argument 1 of ‘firegl_pci_save_state’ from incompatible pointer type
    /usr/src/modules/fglrx/firegl_public.c: In function ‘fglrx_pci_resume’:/usr/src/modules/fglrx/firegl_public.c:841: warning: passing argument 1 of ‘firegl_pci_restore_state’ from incompatible pointer type
    /usr/src/modules/fglrx/firegl_public.c: In function               ‘__ke_pci_find_device’:                                                   
    /usr/src/modules/fglrx/firegl_public.c:2019: warning: ‘pci_find_device’ is deprecated (declared at include/linux/pci.h:477)
    /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_request_irq’: 
    /usr/src/modules/fglrx/firegl_public.c:2962: warning:                      
    ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:68)                                              
    /usr/src/modules/fglrx/firegl_public.c:2962: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
    /usr/src/modules/fglrx/firegl_public.c: At top level:                      
    /usr/src/modules/fglrx/firegl_public.c:5439: warning: ‘kmem_cache_t’ is  deprecated                                                                 
      LD [M]  /usr/src/modules/fglrx/fglrx.o                                   
      Building modules, stage 2.                                               
      MODPOST 1 modules                                                        
    WARNING: could not find /usr/src/modules/fglrx/.libfglrx_ip.a.GCC4.cmd
    for /usr/src/modules/fglrx/libfglrx_ip.a.GCC4                             
    FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol
    '__rcu_read_lock'                                                          
    make[2]: *** [__modpost] Error 1                                           
    make[1]: *** [modules] Error 2                                             
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-rt'
    make: *** [build] Error 2                                                  
    ^Y
    If I hit CONTINUE, it just takes me back to the prompt. Any idea what's going wrong at this point?

    (So close, and yet, so far)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •