Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: For fglrx using people having idle overheating problems and eco friendly people...

  1. #11
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,573

    Default

    Realistically, I don't think so -- but for the short term I can at least find out if that register is known to have bad side effects and make sure we answer any questions the radeontool devs might have.

  2. #12
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    The reason I asked is because the Windows driver seems to do this by default. Is the ultimate goal to replicate the behavior of the Windows driver packages, under Linux?

    Thanks for your insight... it helps us understand where the project is going.

  3. #13
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,573

    Default

    Short answer is yes. There will be some features which we can't offer directly on Linux (anything starting with DX, for example ), but in general we are working towards having the same or comparable functionality across all OSes.

  4. #14
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Any updates on the registers? I would like to use readontool, as I cannot use aticonfig powerstate options (openSUSE 10.3, Driver 8.40, Xgl, cannot pass anything to the Xserver...).

  5. #15
    Join Date
    Sep 2007
    Location
    Patras, Greece
    Posts
    63

    Default

    no luck it seems with my 2600 mobility
    i guess the patch is for cards up to the r500 series?
    aticonfig --set-powerstate doesn't work either... (says powerplay not supported by the hardware...is anything else needed for that one to work?)

  6. #16

    Default

    Quote Originally Posted by gavro View Post
    When I try to run either one of these versions, my entire system freezes. Hard reset (poweroff) is the only way to go.

    I've got a Dell Inspiron 6400 (E1505) with an ATI X1400, running Xgl with fglrx version 8.40.4... OS: openSUSE 10.3 x86_64

    Is there any way to use this tool on my system?
    Battery drainage with the X1400 in linux is true hell..
    I hope you didn't use the provided executable because it is compiled for 32-bit and you use 64-bit.

    @OP
    thank you very very much. I compiled "your" radeontool for 64-bit Gutsy and it worked. The fan-noise was driving me crazy. And now I barely hear it, just like WinXP. I just hope that future fglrx releases fix this as soon as possible. Again thank you.

    My card: x1800xl

  7. #17
    Join Date
    Nov 2007
    Posts
    33

    Default

    unfortunately, i think that 64 bit is not the problem, but something else.

    I hope mr. bridgman from AMD will have some info soon about the differences between various products (x1400 vs x1950pro). the source is there, they can see what registers it touches, so it should not really be a problem..

    another option is for me to get a couple of other radeon cards but i don't have the time for that currently. maybe in the next few weeks I'll know more

  8. #18
    Join Date
    Aug 2007
    Posts
    15

    Default

    I tried your version of Radeontool and it complained with "Radeon control memory not found".

    But I was surprised to find a packaged version on my Ubuntu and it works... but doesn't have the "power low" option...

    So I have this..

    - Radeontool (original, unmodified)
    http://fdd.com/software/radeon/radeontool-1.5.tar.gz

    - Radeontool (adapted for Debian-based system)
    http://packages.debian.org/source/etch/radeontool

    - Radeontool (disabling unused pipes)
    http://nskunca.pbf.hr/~vedran/ati/radontool.tar.gz


    Is there a way to merge all this together?

    Even when the CPU is idle and at 28C, the GPU fans are always at max speed in Linux. It's not the case on Windows. Even more, "aticonfig --set-powerstate=1" (the only powerstate available) says that it can't process the command because thermal control is already on. So, obviously, this tweek with Radeontool would certainly help me to reduce GPU heat, hence fan speed.
    Last edited by francois; 02-21-2008 at 01:59 PM.

  9. #19
    Join Date
    Nov 2007
    Posts
    33

    Default

    Quote Originally Posted by francois View Post
    I tried your version of Radeontool and it complained with "Radeon control memory not found".
    Hi. I've found that the debian version is patched to better detect some ATI cards. What card do you have? Can you post lspci -v and lspci -n output for your card?

    I've modified my version to include the debian changes.

    http://nskunca.pbf.hr/~vedran/ati/ra...-qq-vr2.tar.gz

    I still haven't tested it but will do so as soon as a get home later this evening.

  10. #20
    Join Date
    Aug 2007
    Posts
    15

    Default

    Ok here are my results with ATI Technologies X1950Pro 256MB (PCI-E)

    $ sudo ./radeontool power full (or as it was before using radeontool)

    ### After a few minutes the system is up, the GPU fan is
    ### making more and more noise due to the heat accumulating,
    ### even though the system is idle

    $ sudo ./radeontool power status
    Dynamic clock mode: single block
    Static screen enable: OFF
    Client power enable: OFF
    Lower power mode: OFF
    Static screen mode: OFF
    Disable unused clk: OFF

    $ glxgears

    21579 frames in 5.0 seconds = 4315.619 FPS
    21963 frames in 5.0 seconds = 4392.481 FPS
    28911 frames in 5.0 seconds = 5782.126 FPS
    53904 frames in 5.0 seconds = 10780.643 FPS
    53610 frames in 5.0 seconds = 10721.811 FPS
    53576 frames in 5.0 seconds = 10715.035 FPS

    ### Looks like the GPU is gradually adapting itself to the task
    ### is it? Fan is making loud noise, which is normal

    $ sudo ./radeontool power low

    ### Not even 10 seconds later the GPU fan reduced it's speed.
    ### Much better as it's now at the same level as in Windows.

    $ sudo ./radeontool power status
    Dynamic clock mode: separate blocks
    Static screen enable: OFF
    Client power enable: OFF
    Lower power mode: OFF
    Static screen mode: OFF
    Disable unused clk: ON

    ### Dynamic clock mode as changed to "separete blocks"
    ### Disable unused clk changed to "ON"

    $ glxgears
    44212 frames in 5.0 seconds = 8842.352 FPS
    53202 frames in 5.0 seconds = 10640.377 FPS
    53289 frames in 5.0 seconds = 10657.762 FPS
    53392 frames in 5.0 seconds = 10678.291 FPS
    52767 frames in 5.0 seconds = 10553.257 FPS
    52158 frames in 5.0 seconds = 10431.481 FPS

    ### Looks like the GPU is now getting faster to it's full potential... Other than that, there's nearly
    ### no performance drop. GPU fan slows down as soon as the task is ended, which is great!

    $ lspci -v (only the VGA part here)
    01:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (prog-if 00 [VGA])
    Subsystem: ATI Technologies Inc Unknown device 0b12
    Flags: bus master, fast devsel, latency 0, IRQ 18
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at fbdf0000 (64-bit, non-prefetchable) [size=64K]
    I/O ports at c000 [size=256]
    Expansion ROM at fbdc0000 [disabled] [size=128K]
    Capabilities: <access denied>

    01:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary)
    Subsystem: ATI Technologies Inc Unknown device 0b13
    Flags: bus master, fast devsel, latency 0
    Memory at fbde0000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>

    02:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (prog-if 00 [VGA])
    Subsystem: ATI Technologies Inc Unknown device 0b12
    Flags: fast devsel, IRQ 10
    Memory at d0000000 (64-bit, prefetchable) [disabled] [size=256M]
    Memory at fbef0000 (64-bit, non-prefetchable) [disabled] [size=64K]
    I/O ports at d000 [disabled] [size=256]
    Expansion ROM at fbec0000 [disabled] [size=128K]
    Capabilities: <access denied>

    02:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary)
    Subsystem: ATI Technologies Inc Unknown device 0b13
    Flags: bus master, fast devsel, latency 0
    Memory at fbee0000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>

    $ lspci -n (only the VGA part here)
    01:00.0 0300: 1002:7280
    01:00.1 0380: 1002:72a0
    02:00.0 0300: 1002:7280
    02:00.1 0380: 1002:72a0

    ### Conclusion:
    ###
    ### It works great !!! No loud fan noise from the GPU anymore :-)
    ###
    ### Thanx a lot !!!
    ###
    ### Note that I have 4 display ports, but only the first one is used.
    ###
    ### I don't have a double-head setup so I don't know if the second card
    ### is already turned off by xorg or if Radeontool would control the
    ### second card also.

    Edit: How come ATI hasn't integrated Radeontool's functionalities into fglrx yet?
    Once again, thank you for your mods, it's making my day!
    Last edited by francois; 02-21-2008 at 06:05 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •